Possible enhancements to hg clone script

RESOLVED DUPLICATE of bug 891318

Status

Developer Services
General
--
enhancement
RESOLVED DUPLICATE of bug 891318
6 years ago
3 years ago

People

(Reporter: joey, Assigned: bkero)

Tracking

Details

(Reporter)

Description

6 years ago
Some error output is appearing as a menu choice when atttempting to create/clone a user repository:

% ssh hg.mozilla.org clone foobar
1) yes - create repo
1) clone a private repository
   203) /usr/bin/find: `private': Permission denied.

find may need to -prune the private/ directory or stderr redirected to filter garbage out of the menu list.


For usability a few enhancements might help finding a specific repo to clone within the +/- 400 available options.
  1) alphabetic sort
  2) display common repositories like 'mozilla-central', 'comm-central', etc as a separate list displayed at the bottom.
  3) shorten the overall list by subdir.  If elements like weave-l10n/ x 40, l10n-central/ x 103, etc could be displayed initially as a menu option that when selected would expand and display available choices.  It would reduce the number of options a user may need to review to find the repo to be cloned.
(Reporter)

Comment 1

6 years ago
Also specifying the source repo on the command line might help eliminate some interactive prompting if the arg specified is a full/valid repo:

ssh hg.mozilla.org clone mozilla-central foobar

Updated

5 years ago
Assignee: server-ops-devservices → bkero
Severity: normal → enhancement
Summary: hg.mozilla.org "clone" → Possible enhancements to hg clone script
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891318
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.