Last Comment Bug 785463 - Tweak PurpleBuffer Block size
: Tweak PurpleBuffer Block size
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86 Linux
-- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (pto-ish for couple of days)
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 12:08 PDT by Olli Pettay [:smaug] (pto-ish for couple of days)
Modified: 2012-08-24 12:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (723 bytes, patch)
2012-08-24 12:08 PDT, Olli Pettay [:smaug] (pto-ish for couple of days)
continuation: review+
Details | Diff | Splinter Review
patch (718 bytes, patch)
2012-08-24 12:19 PDT, Olli Pettay [:smaug] (pto-ish for couple of days)
no flags Details | Diff | Splinter Review

Description User image Olli Pettay [:smaug] (pto-ish for couple of days) 2012-08-24 12:08:23 PDT
Created attachment 655085 [details] [diff] [review]
patch

Since the size of the purple buffer has changed, we should tweak the block size.
We could also increase the size of block so that we wouldn't have to allocate
stuff so often, and hopefully cache locality is better.
Comment 1 User image Andrew McCreight [:mccr8] 2012-08-24 12:12:04 PDT
Comment on attachment 655085 [details] [diff] [review]
patch

Review of attachment 655085 [details] [diff] [review]:
-----------------------------------------------------------------

::: xpcom/base/nsCycleCollector.cpp
@@ +703,5 @@
>  {
>  private:
>      struct Block {
>          Block *mNext;
> +         // Try to match the size of a jemalloc bucket size.

remove the second "size" from the comment
Comment 2 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2012-08-24 12:19:00 PDT
Created attachment 655092 [details] [diff] [review]
patch
Comment 3 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2012-08-24 12:29:07 PDT
https://hg.mozilla.org/mozilla-central/rev/45204dc49ac2

Note You need to log in before you can comment on or make changes to this bug.