The default bug view has changed. See this FAQ.

New Tb Appmenu Button Should Show in Calendar Tab and have Calendar Functions

RESOLVED FIXED in 1.9

Status

Calendar
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Sean Smith, Assigned: Paenglab)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120824030530

Steps to reproduce:

After being able to hide the menu bar by default and then landing bug 650170 the appmenu button should also show when you are in the calendar tab (if Lightning is installed).  Some of the calendaring tasks should also be in the new appmenu.


Actual results:

Tb appmenu button is not shown on the toolbar in the calendar tab.


Expected results:

The appmenu button should show in the calendar tab and ideally be populated with common calendaring tasks.
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

5 years ago
Component: Toolbars and Tabs → General
Product: Thunderbird → Calendar

Comment 1

5 years ago
Problem also exists with User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0a1 Build ID: 20120824030532

The menu item Events and Tasks is missing from the appmenu button.
(Assignee)

Comment 2

5 years ago
Created attachment 655285 [details] [diff] [review]
WIP

This patch contains only the AppMenu integration.

Philipp, please can you help to integrate 'button-appmenu' from mailWindowOverlay.xul into the calendar- and task-toolbar. After the IRC talk some time ago this should be doable, but I have no clue how to do this.
Attachment #655285 - Flags: feedback?(philipp)

Comment 3

5 years ago
I think there are two problems here:

1) The app menu button should be always visible like in Firefox. Currently it is only visible in mail tabs but is not visible in other tabs like add-ons tab, content tabs, calendar tab, ... This should be fixed in Thunderbird. Current workaround: Move the button from mail toolbar to the global tab toolbar.

2) Reintegrate all or most calendar functions into the new app menu, i.e. the functions that are currently available from File menu, Edit menu, View menu, and Events & Tasks menu. This can be done in Lightning.
(Assignee)

Comment 4

5 years ago
(In reply to Stefan Sitter from comment #3)
> I think there are two problems here:
> 
> 1) The app menu button should be always visible like in Firefox. Currently
> it is only visible in mail tabs but is not visible in other tabs like
> add-ons tab, content tabs, calendar tab, ... This should be fixed in
> Thunderbird.

If I knew how to do this, I would do this. I'm trying to persuade mconley to help on this, but he has a lot of other thing. Until it's globally fixed we should try to fix this only for Lightning. Maybe I can then use this approach for the global use ;)

> 2) Reintegrate all or most calendar functions into the new app menu, i.e.
> the functions that are currently available from File menu, Edit menu, View
> menu, and Events & Tasks menu. This can be done in Lightning.

My WIP patch is for doing this. Edit and View menu are in the next version.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

5 years ago
Created attachment 655335 [details] [diff] [review]
WIP v2

Now all menu entrys implemented in AppMenu.

Still need help to implement the AppButton on the Calendar toolbars.
Attachment #655285 - Attachment is obsolete: true
Attachment #655285 - Flags: feedback?(philipp)
Attachment #655335 - Flags: feedback?(philipp)
(Assignee)

Comment 6

5 years ago
Comment on attachment 655335 [details] [diff] [review]
WIP v2

Because the AppButon in all toolbars is done in bug 785692 I'll ask for review of this patch for adding the menus in AppMenu.

I'm also asking for approval‑calendar‑aurora to implement this menu from beginning of the AppMenu.
Attachment #655335 - Flags: review?(philipp)
Attachment #655335 - Flags: feedback?(philipp)
Attachment #655335 - Flags: approval-calendar-aurora?
Comment on attachment 655335 [details] [diff] [review]
WIP v2

Looks good, r=philipp
Attachment #655335 - Flags: review?(philipp)
Attachment #655335 - Flags: review+
Attachment #655335 - Flags: approval-calendar-aurora?
Attachment #655335 - Flags: approval-calendar-aurora+
(Assignee)

Comment 8

5 years ago
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/977cc1465513
and to comm-aurora: http://hg.mozilla.org/releases/comm-aurora/rev/bef5c9d145f7
Assignee: nobody → richard.marti
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.8

Comment 9

5 years ago
What should happen with menu commands that didn't make it into the new app menu, for example the Open Calendar File command? This command could be added to the calendar list context menu but are there other commands that are now not available anymore?
(Assignee)

Comment 10

5 years ago
It looks I've missed this menu command. I think this needs a followup bug. I'm not aware of other missing commands.

With ALT or on Linux F10 the standard menu is still available.

Updated

5 years ago
Depends on: 792849

Updated

5 years ago
Target Milestone: 1.8 → 1.9
(In reply to Richard Marti [:Paenglab] from comment #10)
> It looks I've missed this menu command. I think this needs a followup bug.
> I'm not aware of other missing commands.
> 
> With ALT or on Linux F10 the standard menu is still available.

Has the follow-up bug for adding at least the "Open Calendar File" command to the Appmenu already been filed?
(Assignee)

Updated

4 years ago
Depends on: 808412
You need to log in before you can comment on or make changes to this bug.