Scrollbar stops updating when zoom-in and zoom-out of the page with extensions like and including statusbarex

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: danialhorton, Unassigned)

Tracking

({regression})

17 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20120822 Firefox/16.0
Build ID: 20120822042007

Steps to reproduce:

New profile
install statusbarex and enable the addonsbar
navigate to http://www.chia-anime.com/alpha/K (url can be substituted with any long page,  a facebook wall or photo comment block for instance)

zoom in a few levels (ctrl-+ 3x) then refresh 


Actual results:

scrollbar will no longer update


Expected results:

scrollbar continues to work
(Reporter)

Comment 3

6 years ago
I'm aware

I'm re-narrowing the range, when i first tried there were less builds in the Mozilla Inbound folder then there are now.

For example, there is a build for 20120726200916 now in the folder between those 2 tinderbox builds.
(Reporter)

Comment 4

6 years ago
Hmm, i might have been in the PGO inbound folder before or something, because 

20120726174818 exists with 4bfa8a24fe41 but 20120726180140 does not with 4bfa8a24fe41

alright, 

MI
Good
20120726195817
http://hg.mozilla.org/integration/mozilla-inbound/rev/541286c00397

Bad
20120726200916
http://hg.mozilla.org/integration/mozilla-inbound/rev/73d5c4461f12

Updated

6 years ago
Keywords: regression
(Reporter)

Comment 7

6 years ago
and this has now followed 17 to aurora -_-
Hardware: x86_64 → x86
Version: 16 Branch → 17 Branch

Comment 8

6 years ago
I can confirm this, as I'm receiving bug reports on my add-on (NoSquint) after users are upgrading to Firefox 17.

I've created a screencast showing the issue and how to reproduce it.  It is highly sporadic.

http://youtu.be/yS6ZPymowdo

Comment 9

6 years ago
I should have mentioned: I can reproduce this issue with a clean profile.  No add-ons are needed, although with NoSquint the problem is much more consistent (probably because NoSquint modifies the zoom level at a slightly different time during page load than native Firefox does).

Comment 10

6 years ago
A NoSquint user filed a bug at https://github.com/jtackaberry/nosquint/issues/50 which may have more relevant details.

I can reproduce this on Ubuntu 12.10 x86_64, and original submitter of the NoSquint bug was using Ubuntu 11.10 x86.  I've received other bug reports by email and have asked them further information about their platform, but considering I'm seeing on different architectures on Linux and Danial saw it on Windows x86, this looks like a platform agnostic bug.

Updated

6 years ago
Status: UNCONFIRMED → NEW
status-firefox17: --- → affected
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
Ever confirmed: true
I think this is fixed in nightlies. So it would be good to find out what fixed this so we can make sure to uplift it to the right places.

Comment 12

6 years ago
Not able to reproduce this with 18b1.
status-firefox17: affected → ---
tracking-firefox18: ? → ---
tracking-firefox19: ? → ---
tracking-firefox20: ? → ---
(In reply to Timothy Nikkel (:tnikkel) from comment #11)
> I think this is fixed in nightlies. So it would be good to find out what
> fixed this so we can make sure to uplift it to the right places.

Danial, do you agree this is fixed?
Flags: needinfo?(danialhorton)
(Reporter)

Comment 14

3 years ago
This has been fixed for a very very long time.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(danialhorton)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.