[tzm-Tfng] New localization: Central Atlas Tamazight, Tifinagh script

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: asissen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Hello,
I am a developer of Berber origin who notes that his language is not listed in the "localization community directory". To my knowledge, there is a variation on the list but has taken a specific appointment. This is the Kabyle.

But as stated in the note "Tags for Identifying Languages" located in the following page: http://www.ietf.org/rfc/rfc4646.txt, it seems that a specification is required. If I rely on the note I can easily deduce, in my case:
- MZG-Latn: Written using Latin script Tamazight (Tamazight is the original name of the Berber language)
- MZG-Tfng: Written using Tifinagh Tamazight script.

We may, in the near future, specify the country in this way:

# In Tifinagh:

- MZG-Tfng-dz: Tamazight written in Tifinagh (countries: Algeria)
- MZG-Tfng-ma: Tamazight written in Tifinagh (country: Morocco)
- MZG-Tfng-ly: Tamazight written in Tifinagh (country: Libyan)
- ...
  Same in Latin:

- MZG-Latn-dz: Tamazight written in Latin (countries: Algeria)
- MZG-Latn-ma: Tamazight written in Latin (country: Morocco)
- MZG-Latn-ly: Tamazight written in Latin (country: Libyan)
- ...
For more information:

- Tamazight: http://fr.wikipedia.org/wiki/Berbère (French)
- Tifinagh (en): http://fr.wikipedia.org/wiki/Tifinagh (French)
- Tifinagh (in): http://en.wikipedia.org/wiki/Tifinagh (English)

In my case I want to develop a version of firefox in Tamazight with two scripts: Latin and Tifinagh. You may notice the style by going to my website where I insert a virtual keyboard (http://www.afersig.com).

Cordially.
Afersig
Assignee: nobody → registration
Component: Localization → Registration & Management
OS: Windows XP → All
Product: Core → Mozilla Localizations
Hardware: x86 → All
There are numerous languages that fall under the descriptor of "Berber" (or even "Tamazight"):
http://www.ethnologue.com/show_family.asp?subid=57-16

Which of these languages are you referring to? Where is the primary speakership located?

I should note that 'mzg' refers to 'Monastic Sign Language', which I assume is not what you intended to indicate. Where did you get that identifier from?

Also, I should note that there is a language tag 'ber' which refers to the collection of Berber languages, but that is likely too general of a group to fall under a single locale.

Once we sort out which language you intend to localize, then we can go about getting your started with the process.

You might also want to take a look at the documentation here:
https://wiki.mozilla.org/L10n:Contribute
https://wiki.mozilla.org/L10n:Starting_a_localization
Summary: About new language → New localization: Berber
(Reporter)

Comment 2

6 years ago
Thank you for your quick response,

I pressed the link I put on my previous message. I was inspired by the following link: http://www.ietf.org/rfc/rfc4646.txt to form the initials of our language.

Now that you had indicated that "ber" is used to denote the Tamazight language in the Mozilla jargon, I would like to know if there is a way to help to develop a translation Berber.

If I can be helpful, I am available for any contribution.

Cordially.
(Reporter)

Comment 3

6 years ago
Following your request for the group of Berber dialects. Actually, I just realize, thanks to your link (http://www.ethnologue.com/show_language.asp?code=tzm) that this dialect is referenced as "ISO 639-3: tzm."
(In reply to Afersig from comment #3)
> Following your request for the group of Berber dialects. Actually, I just
> realize, thanks to your link
> (http://www.ethnologue.com/show_language.asp?code=tzm) that this dialect is
> referenced as "ISO 639-3: tzm."

Just to clarify, you would like to localize Central Atlas Tamazight ('tzm'), spoken in central Morocco (and perhaps nearby parts of Algeria), as described here:
http://en.wikipedia.org/wiki/Central_Atlas_Tamazight

That article states that Central Atlas Tamazight is primarily written in both Tifinagh script ('Tfng') [1] and Latin script ('Latn').

You state that you would like to localize both scripts. This requires two separate locales, which would probably best be served by two separate bugs. I will associate this bug with the 'tzm-Tfng' locale, and I recommend you file a second bug for 'tzm-Latn'.

[1] http://en.wikipedia.org/wiki/Tifinagh
Summary: New localization: Berber → [tzm-Tfng] New localization: Central Atlas Tamazight, Tifinagh script

Comment 5

6 years ago
I'd rather focus on the more popular script now, and then follow up with a transcription of the other.

Are there algorithms mapping one to the other?
(In reply to Axel Hecht [:Pike] from comment #5)
> I'd rather focus on the more popular script now, and then follow up with a
> transcription of the other.

It doesn't look like we'll be able to determine which one is more "popular", as each has common use in particular areas. However...

> Are there algorithms mapping one to the other?

Using [1] as a guide, it seems the conversion process is only reliable in one direction, Tifinagh to Latin, as some of the Latin characters are conflated.

So, with that in mind, it might make sense to do the main localization in Tifinagh and then automatically convert to Latin.

[1] http://en.wikipedia.org/wiki/Tifinagh#Characters
(Reporter)

Comment 7

6 years ago
Thank you guys for your advice and comments so precious. I created another bug for the Latin transcription and made ​​available to users a converter (Latin -> Tifinagh and Tifinagh -> Latin)
This locale registration bug is being resolved as INCOMPLETE because it has not been updated since before the final Firefox 10esr release on 2013-01-08. It is assumed that there has not been any progress in developing the desired localization since that time.

If you feel this bug has been closed in error, please reopen it and provide a status update for your locale.

In addition, please be sure to follow the guidelines listed on the wiki for creating a new localization:

https://wiki.mozilla.org/L10n:Starting_a_localization

[Mass change filter: l10n-new-incomplete-fx10esr]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.