Rotating from portrait to landscape with tab menu open: Tabs partly hidden

VERIFIED FIXED in Firefox 18

Status

()

VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: aryx, Assigned: sriram)

Tracking

({regression})

16 Branch
Firefox 18
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected, firefox18 verified, fennec+)

Details

Attachments

(1 attachment)

Firefox for Android 20120826, Android 4.1.1 (stock), Google Nexus S

When rotating from portrait to landscape mode with the tab menu open, the tab list will have 100% height (normally it hasn't) and only a part of it will show the tabs and be scrollable, the rest is a dark grey area.

Steps to reproduce:
1. Open at least 3 tabs.
2. Get into portrait mode.
3. Open tab menu.
4. Rotate to landscape mode.
I think this is a regression. Sriram?
Assignee: nobody → sriram
tracking-fennec: --- → ?
status-firefox17: --- → affected
Keywords: regression, regressionwindow-wanted
Another STR :: new profile, launch Fennec (08/27), and rotate to landscape
Last good: 20120821
First bad: 20120822

Updated

6 years ago
Keywords: regressionwindow-wanted
(Assignee)

Comment 6

6 years ago
Created attachment 655703 [details] [diff] [review]
Patch

The animation check is not needed when it's not a sidebar. The layout is full-screen, and would actually go back and forth when sync is enabled.
Attachment #655703 - Flags: review?(michael.l.comella)
Comment on attachment 655703 [details] [diff] [review]
Patch

Review of attachment 655703 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #655703 - Flags: review?(michael.l.comella) → review+
The patch this bug fixes (bug 779321) was uplifted into 16 so please make sure this gets uplifted as well.

Updated

6 years ago
Duplicate of this bug: 763406
Seems like according to bug 763406 comment #4; this is an issue across all branches.

Updated

6 years ago
Version: Trunk → Firefox 17

Updated

6 years ago
status-firefox16: --- → affected
status-firefox18: --- → affected

Comment 11

6 years ago
Comment 3 and 16.0b1 being affected are inconsistent.
(In reply to Scoobidiver from comment #11)
> Comment 3 and 16.0b1 being affected are inconsistent.

16 should be affected. The patch that caused the problem (bug 779321) was uplifted in Aurora when Aurora was still 16.

Updated

6 years ago
Blocks: 779321
Version: Firefox 17 → Firefox 16
tracking-fennec: ? → +
https://hg.mozilla.org/mozilla-central/rev/29e1983201a5
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

6 years ago
status-firefox18: affected → ---
This issue is not longer reproducible on the latest Nightly. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-12)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
You need to log in before you can comment on or make changes to this bug.