Assertion failure: v.isString(), at jsbool.cpp:198

RESOLVED DUPLICATE of bug 785576

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 785576
6 years ago
4 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update,ignore])

(Reporter)

Description

6 years ago
The following testcase asserts on mozilla-central revision f077de66e52d (run with -n -m -a):


var UBound = 0;
var status = '';
var statusitems = [];
addThis();
gczeal(2);
var arrUndef = [ , undefined, eval('var x = 0') ];
function addThis()
  statusitems[UBound] = status;
UBound++;
try {
  for (var i=0; i<UBound; i++)
  exitFunc ('test');
} catch(exc1) {}
evaluate('const libdir = "foo"');
evaluate("\
var appendToActual = function(s) {\
  gczeal = function() { };\
  schedulegc = function() { };\
  gcslice = function() { };\
  selectforgc = function() { };\
}\
");
evaluate("\
if ( statusitems[i]   ) \
var x;\
");
(Reporter)

Comment 1

6 years ago
S-s due to gczeal involved. Trying a bisect now, but not sure if this is stable enough.
Whiteboard: [jsbugmon:update,bisect]
(Reporter)

Updated

6 years ago
Whiteboard: [jsbugmon:update,bisect] → [jsbugmon:update]
(Reporter)

Comment 2

6 years ago
JSBugMon: Bisection requested, result:
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   103141:455ed4a415aa
user:        Eric Faust
date:        Wed Aug 22 22:05:21 2012 -0700
summary:     Bug 781855 - Fix incorrectly shadowing 'own' properties in the case of prototypal setters. (r=bhackett)
(Reporter)

Comment 3

6 years ago
Ccing efaust and bhackett per comment 2.
(Reporter)

Updated

6 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
(Reporter)

Comment 4

6 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision 8af2ff9c6018).
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785576
Group: core-security
You need to log in before you can comment on or make changes to this bug.