All users were logged out of Bugzilla on October 13th, 2018

Mozilla crashes while loading saved form output

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: guy_hutchison, Assigned: harishd)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I saw possible rendering error in the drop-down dialog on a form page, so
I saved the form as HTML to try and reproduce it.  Attempting to load the
saved HTML file crashes Mozilla.  The same page loads OK when loaded using
Communicator 4.7, and renders correctly (more or less) when viewed from web
server by both Moz 0.8 and NS 4.7.

HTML file attached.

System info:
Mozilla version 0.8
OS: Linux Mandrake 7.1
(Reporter)

Comment 1

18 years ago
Created attachment 32950 [details]
Testcase for bug 78576

Comment 2

18 years ago
Reporter can you get the stacktrace from the crash for us? Thanks in advance.
Severity: major → critical
Keywords: crash
(Reporter)

Comment 3

18 years ago
Okay, I have a stack trace, but it sure wasn't easy to figure out how to get
it...  I will attach the stack trace as a file, or (if you can search the
FullCircle database) you can look for a report that has "78576" and
"harishd@netscape.com" in the description.
(Reporter)

Comment 4

18 years ago
Created attachment 33113 [details]
Stack trace, from FullCircle dialog

Comment 5

18 years ago
When you submitted it, it should have given you a number something to the effect
of TBXXXXXXXX could you give us that number please :) Sorry for it being such a
problem.
(Reporter)

Comment 6

18 years ago
Okay, talkback information for this bug can be found in TB30006507Q,
TB29975468Z, TB29920459M, or TB29920412K.

Also, while trying to repeat the crash this morning, I found more information:
The form opens correctly if the "File|Open File" (with "wa_form.html" as arg) is
used, but crashes if "File|Open Web Location" (with
"file:/home/ghutchis/wa_form.html" as arg) is used to open the file.
(Reporter)

Comment 7

18 years ago
Attempted to reproduce on Mozilla 0.9.  I was unable to reproduce the problem
(the page loaded just fine).  I tried to go to mozilla.org to update the bug,
and the browser crashed.  Not sure if this is related, but it's TB30163065K.
(Reporter)

Comment 8

18 years ago
Reproduced failure in mozilla 0.9.  Typed "file:/home/ghutchis/wa_form.html" in
location bar and got talkback dialog.  TB30168895Y

Comment 9

18 years ago
Mozilla/5.0 (X11; U; Linux 2.4.2 i586; en-US; rv:0.9+) Gecko/20010508
WFM:
Clicking the attachment link worked fine.
I then saved it locally as a file (home/XXX/showattachament.html) and opened it
using Open Web Location - worked too. Just typing file:///home ... worked as well.
(Assignee)

Comment 10

18 years ago
I don't see the crash either. Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
Verified on
build: 2001-05-17-04-Trunk
platform: Win NT

The site is loaded fine with both 'Open file' and 'Open Web location' options.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.