Closed Bug 785826 Opened 8 years ago Closed 8 years ago

Dispatch error message in JS console on deprecated functions.

Categories

(Add-on SDK Graveyard :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ochameau, Assigned: ochameau)

Details

Attachments

(1 file)

We have some deprecated functions like global postMessage function in page-mod, that currently only dispatch warning messages in JS console.
But it would be better to dispatch error messages instead as reviewer mainly cares about those.
Attached file Pull request 536
Erik, you may have better sense what kind of message we should throw in JS console for reviewers...
Assignee: nobody → poirot.alex
Attachment #655978 - Flags: review?(evold)
what you have looks good
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/39a0deb87dd11ced5e4d917f1a6104b726f33f10
Bug 785826: Display error in JS console when using deprecated APIs.

https://github.com/mozilla/addon-sdk/commit/d826800d1a8c70908fd80072379e0b7c96041962
Merge pull request #536 from ochameau/bug/785826-error-on-deprecate

Fix Bug 785826: Display error in JS console when using deprecated APIs. r=@erikvold
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.11
Attachment #655978 - Flags: review?(evold) → review+
You need to log in before you can comment on or make changes to this bug.