###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant'

RESOLVED DUPLICATE of bug 784190

Status

()

RESOLVED DUPLICATE of bug 784190
6 years ago
4 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
While running debug build of b2g on raspberry pi (debian,wheezy,armv6)
I see some assertion error from GC
./b2g -profile /root/profile:
.........
--DOMWINDOW == 16 (0x405639cc) [serial = 14] [outer = 0x405633e0] [url = about:blank]
--DOMWINDOW == 15 (0x4056324c) [serial = 12] [outer = 0x40562c60] [url = about:blank]
###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant', file xpcom/base/nsCycleCollector.cpp, line 1762
XXX FIXME : Got a mozContentEvent: accessibility-screenreader
###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant', file xpcom/base/nsCycleCollector.cpp, line 1762
WARNING: Idle observer not found in list of idle observers. No idle observer removed.: file dom/base/nsGlobalWindow.cpp, line 8820
###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant', file xpcom/base/nsCycleCollector.cpp, line 1762
--DOMWINDOW == 14 (0x405646ec) [serial = 18] [outer = 0x40564100] [url = about:blank]
###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant', file xpcom/base/nsCycleCollector.cpp, line 1762
###!!! ASSERTION: nsCycleCollectionParticipant shouldn't change!: 'result->mParticipant == aParticipant', file xpcom/base/nsCycleCollector.cpp, line 1762
*** UTM:SVC TimerManager:notify - notified @mozilla.org/addons/integration;1
.........
(Reporter)

Comment 1

6 years ago
baku told it could be related to bug https://bugzilla.mozilla.org/show_bug.cgi?id=784190

Comment 2

6 years ago
Stack trace would be great.
(Reporter)

Comment 3

6 years ago
I've applied patch https://bug784190.bugzilla.mozilla.org/attachment.cgi?id=654657, and don't see this assertion anymore
Will try to get stack soon
(Reporter)

Comment 4

6 years ago
#0  GCGraphBuilder::AddNode (this=0x44bd1bec, s=0x4fe16928, aParticipant=0x436c2898)
    at xpcom/base/nsCycleCollector.cpp:1764
#1  0x429e76c4 in AddPurpleRoot (builder=..., root=0x4fe16928, cp=0x436c2898)
    at xpcom/base/nsCycleCollector.cpp:1967
#2  0x429e78c0 in nsPurpleBuffer::SelectPointers (this=0x40669050, aBuilder=...)
    at xpcom/base/nsCycleCollector.cpp:1005
#3  0x429e8778 in SelectPurple (builder=..., this=0x40669000)
    at xpcom/base/nsCycleCollector.cpp:2076
#4  nsCycleCollector::BeginCollection (this=0x40669000, aMergeCompartments=<optimized out>, aListener=0x0)
    at xpcom/base/nsCycleCollector.cpp:2785
#5  0x429e89b8 in BeginCollection (aListener=<optimized out>, aMergeCompartments=<optimized out>, this=<optimized out>)
    at xpcom/base/nsCycleCollector.cpp:2769
#6  nsCycleCollectorRunner::Run (this=0x40613650) at xpcom/base/nsCycleCollector.cpp:3106
#7  0x429c75d4 in nsThread::ProcessNextEvent (this=0x40608270, mayWait=<optimized out>, result=0x44bd1d3f)
    at xpcom/threads/nsThread.cpp:624
#8  0x42943568 in NS_ProcessNextEvent_P (thread=0x40608270, mayWait=<optimized out>)
    at obj-build-b2g-rsppi-dbg/xpcom/build/nsThreadUtils.cpp:220
#9  0x429c6edc in nsThread::ThreadFunc (arg=0x40608270) at xpcom/threads/nsThread.cpp:257
#10 0x40113d44 in _pt_root (arg=0x40633180) at nsprpub/pr/src/pthreads/ptthread.c:156
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784190
You need to log in before you can comment on or make changes to this bug.