Add 10 new Win64 builders to production

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: coop, Assigned: hwine)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [capacity][buildslaves])

(Reporter)

Description

5 years ago
We just had 10 w64 machines re-imaged in bug 780022:

w64-ix-slave101.winbuild.scl1.mozilla.com
w64-ix-slave102
w64-ix-slave103
w64-ix-slave104
w64-ix-slave105
w64-ix-slave106
w64-ix-slave107
w64-ix-slave108
w64-ix-slave109
w64-ix-slave110

To get these into production on the releng side, we need to:
* add the new slaves to slavealloc
* add new slaves to buildbot-configs (in staging,preproduction,production)
* copy .ssh/ from an existing production slave (must get authorized
(Reporter)

Comment 1

5 years ago
(In reply to Chris Cooper [:coop] from comment #0)
> * copy .ssh/ from an existing production slave (must get authorized

cut-n-paste fail

Must get authorized_keys and known_hosts from .ssh/ in the copy. In short, make sure the entire .ssh/ dir  makes it over to ensure we can automatically connect to thing like stage.m.o.
(Assignee)

Updated

5 years ago
Assignee: nobody → hwine
(Assignee)

Comment 2

5 years ago
(In reply to Chris Cooper [:coop] from comment #1)
> Must get authorized_keys and known_hosts from .ssh/ in the copy. In short,
> make sure the entire .ssh/ dir  makes it over to ensure we can automatically
> connect to thing like stage.m.o.

Notes for the documentation I'll generate:
 - you can not scp _to_ a windows box, so must scp push a tarball to a linux box (e.g. a build master)
 - you can use scp connections to copy the tarballs to the new machine & expand them
 - you can not _test_ the new ssh files from an ssh connection to the windows box
 - to test, you must VNC into the w64 box, and try a connect or two to ensure the known_hosts file is being recognized
 - since you should have the host already entered & enabled in slavealloc, use the VNC session to reboot the box after test, so it gets a new tac file.
Blocks: 780022
(Assignee)

Comment 3

5 years ago
Done:
 - production_config.py landed in bug 784850 comment #11 for reconfig
 - slavealloc updates done in bug 784850 comment #10
 - ssh dirs copied using approach in comment #2
 - all new slaves rebooted and assigned to build masters
 - some have been assigned jobs and successfully completed builds
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.