Pages with big favicons don't create pretty shortcuts

RESOLVED DUPLICATE of bug 783921

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 783921
6 years ago
6 years ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 655767 [details]
Patch

I added some nice high res favicons to the minimart. They look a little.... messed up when drawn as launcher icons because they're bigger than what my phone wants. We should either

a.) Just draw these the same as we do for webapps (i.e. scale the icon to the right size and don't add a background

or b.) Draw them to fit inside the box

I'm going to take b here so that there's a difference between webapps and favicons, BUT... I'm not sure that is good enough of a reason. Opinion?
(Assignee)

Comment 1

6 years ago
Created attachment 655768 [details] [diff] [review]
Patch
Assignee: nobody → wjohnston
Attachment #655767 - Attachment is obsolete: true
Attachment #655768 - Flags: review?(mark.finkle)
(Assignee)

Comment 2

6 years ago
Created attachment 655769 [details]
Screenshot of both options
(Assignee)

Updated

6 years ago
Attachment #655769 - Attachment is patch: false
Attachment #655769 - Attachment mime type: text/plain → image/png
Comment on attachment 655768 [details] [diff] [review]
Patch

Help me understand this first. When you say "favicon" and  "shortcut", does that mean you are just adding a shortcut to the homescreen? or are you installing a webapp?
(Assignee)

Comment 4

6 years ago
Heh. We need to refine our language here, but I'm talking about adding a shortcut to the homescreen. i.e. cases where we're drawing our special rectangle behind the icon.
OK. Shortcuts, not WebApps, should always use the "background", so using approach B should be the right way.
(Assignee)

Comment 6

6 years ago
I moved this patch to bug 783921.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783921
(Assignee)

Comment 7

6 years ago
Comment on attachment 655768 [details] [diff] [review]
Patch

I fixed this in bug 783921
Attachment #655768 - Flags: review?(mark.finkle)
You need to log in before you can comment on or make changes to this bug.