IonMonkey: Assertion failure: [barrier verifier] Unmarked edge: method, at jsgc.cpp:5264

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: decoder, Assigned: dvander)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Other Branch
x86
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr10 unaffected, firefox-esr17 unaffected)

Details

(Whiteboard: [jsbugmon:update][ion:p1:fx18])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The following testcase asserts on ionmonkey revision 92b9b2840a79 (run with --ion -n -m --ion-eager):


function writeHeaderToLog( string ) {}
writeHeaderToLog(-0, this);
gczeal(4);
writeHeaderToLog(0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9,
           0,1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7,8,9);
(Reporter)

Comment 1

6 years ago
Without gczeal, this can also yield the following assertion:

Assertion failure: co->script == __null, at jsinfer.cpp:2261
Whiteboard: [jsbugmon:update] → [jsbugmon:update][ion:p1:fx18]
(Reporter)

Updated

6 years ago
Duplicate of this bug: 787815
Created attachment 659379 [details] [diff] [review]
fix
Assignee: general → dvander
Status: NEW → ASSIGNED
Attachment #659379 - Flags: review?
Attachment #659379 - Flags: review? → review?(terrence)
Comment on attachment 659379 [details] [diff] [review]
fix

Review of attachment 659379 [details] [diff] [review]:
-----------------------------------------------------------------

Looks correct.
Attachment #659379 - Flags: review?(terrence) → review+
http://hg.mozilla.org/projects/ionmonkey/rev/18142c3076a1

Thanks for the quick review!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
JSBugMon: This bug has been automatically verified fixed.

Updated

6 years ago
status-firefox-esr10: --- → unaffected
Group: core-security
status-firefox-esr17: --- → unaffected
You need to log in before you can comment on or make changes to this bug.