Last Comment Bug 786181 - [adbe 3325048] Flash 11.4.402.265 is laggy in Firefox 17.0a1 on WeatherSpark
: [adbe 3325048] Flash 11.4.402.265 is laggy in Firefox 17.0a1 on WeatherSpark
Status: RESOLVED INCOMPLETE
[flash-11.4]
: qawanted
Product: External Software Affecting Firefox
Classification: Components
Component: Flash (Adobe) (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://weatherspark.com/#!dashboard;q...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 01:54 PDT by Doug Halamay
Modified: 2016-04-26 10:57 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
DxDiag (54.45 KB, text/plain)
2012-08-28 15:36 PDT, Doug Halamay
no flags Details

Description Doug Halamay 2012-08-28 01:54:52 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120827030549

Steps to reproduce:

Navigated to weatherspark.com, with a fresh profile.  For example: http://weatherspark.com/#!dashboard;q=Corvallis%2C%20OR%2C%20USA




Actual results:

Input lag is evident in the browser window as you move the cursor over the temperature graphs (the crosshairs lag considerably following the cursor).


Expected results:

There should be little if any lag.  This seems to have started with the new Flash 11.4 update (I don't recall it being there with 11.3), but it might also be Firefox-related.

There does not appear to be any problem with Flash 11.4 in Chrome (21.0.1180.83) or IE9.
Comment 1 Loic 2012-08-28 03:59:25 PDT
I tried with Flash 11.2.202.235 and FF17, there is no lag. So the issue is probably with new Flash 11.4.
Comment 2 Doug Halamay 2012-08-28 13:28:22 PDT
Per a suggestion from the MozillaZine forums, I tried disabling Protected Mode in Flash and that fixed the problem.  So it looks like there is a problem with the interaction between FF and Flash's Protected Mode (again...).
Comment 3 smadayag 2012-08-28 14:19:59 PDT
anyone else able to reproduce? i am unable to reproduce testing, Firefox 14,15 and 18 using flash player 11.4.402.265.

would you mind to post your dxdiag output and a video if possible?  thanks...
Comment 4 smadayag 2012-08-28 14:32:01 PDT
unable to reproduce on Firefox 16, aurora, also.  where can i download version 17?
Comment 5 Loic 2012-08-28 14:39:01 PDT
Here: ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora/ (Firefox 17 builds)
Comment 6 smadayag 2012-08-28 15:26:41 PDT
thanks for the link.  unfortunately, i'm also unable to reproduce on Firefox 17.
Comment 7 Doug Halamay 2012-08-28 15:36:13 PDT
Created attachment 656234 [details]
DxDiag

Here's my dxdiag output.  I'll work on seeing if I can put together a movie.
Comment 8 smadayag 2012-08-28 16:04:22 PDT
thanks.  placed a request to our lab services for a similar radeon card.  i won't have access to it until thursday.  i'll post back then.
Comment 9 Doug Halamay 2012-08-28 16:05:49 PDT
Here's a Youtube video of what I'm seeing.  It's actually worse than it looks in the video, since it makes the whole Firefox interface slow down (when I mouse over the Flash content and then off to the FF interface, it takes a while to catch up).

http://youtu.be/pp-aEIc-Di0?hd=1
Comment 10 Doug Halamay 2012-08-28 16:13:20 PDT
As a comparison, this is what it looks like when I set ProtectedMode=0.

http://youtu.be/-hS6-8jECs0?hd=1
Comment 11 smadayag 2012-08-30 17:21:58 PDT
ok, i am able to reproduce the issue on Win8 Firefox 17.0a2 Flash Player 11.4.402.265, but not in Firefox 15.  i am assuming the issue may be a regression in Firefox.  

can you verify, if it's not reproducible for you in Firefox 15?  thanks...
Comment 12 Alice0775 White 2012-08-30 17:54:17 PDT
I noticed following strange behavior in Firefox9.0.1 - Nightly18.0a1, Windows7 x64, Flash Player 11.4.402.265.

When reproduce the issue,
Right click on the chart(flash)and select 1st menu item to popup setting dialog of flash, and close it.
Then, the problem is gone unless I change the tab or window.
Comment 13 Doug Halamay 2012-08-30 22:08:56 PDT
(In reply to smadayag from comment #11)
> ok, i am able to reproduce the issue on Win8 Firefox 17.0a2 Flash Player
> 11.4.402.265, but not in Firefox 15.  i am assuming the issue may be a
> regression in Firefox.  
> 
> can you verify, if it's not reproducible for you in Firefox 15?  thanks...

I just checked it out and the problem definitely still exists for me in FF15.  And it goes away with ProtectedMode=0 in FF15 as well.
Comment 14 Doug Halamay 2012-08-30 22:10:21 PDT
(In reply to Alice0775 White from comment #12)
> I noticed following strange behavior in Firefox9.0.1 - Nightly18.0a1,
> Windows7 x64, Flash Player 11.4.402.265.
> 
> When reproduce the issue,
> Right click on the chart(flash)and select 1st menu item to popup setting
> dialog of flash, and close it.
> Then, the problem is gone unless I change the tab or window.

And, yes, I can confirm this behavior as well.  If I open the "Settings" dialog for Flash Player, choose a tab and then click "Close", the lag goes away temporarily until I mouse out of the window.
Comment 15 smadayag 2012-09-05 13:50:11 PDT
thanks everyone.  i must have clicked on the content when i was in Firefox 15.  as stated, clicking or right-clicking the content temporarily resolves the lag.

we are tracking the issue internally in #3325048...
Comment 16 smadayag 2012-10-16 14:34:03 PDT
our internal bug has been closed verified fix in 11.5.  the next beta refresh should pick up the change.

for those wanting to test, please grab tomorrow's refresh build here:
http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11-5/
Comment 17 Georg Fritzsche [:gfritzsche] 2013-04-17 01:13:37 PDT
Adding qawanted to confirm this as fixed as well.
Comment 18 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2016-04-26 10:57:35 PDT
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.

Note You need to log in before you can comment on or make changes to this bug.