Closed Bug 786216 Opened 8 years ago Closed 8 years ago

Firefox 17 fails to respect evenodd fill-rule

Categories

(Core :: SVG, defect)

17 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox15 --- unaffected
firefox16 --- unaffected
firefox17 + verified

People

(Reporter: epinal99-bugzilla2, Assigned: longsonr)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

STR:
1) Open https://en.wikipedia.org/wiki/File:QR_Code_Structure_Example_2.svg
2) Click on the SVG image to open directly in the tab
(URL is https://upload.wikimedia.org/wikipedia/commons/a/a5/QR_Code_Structure_Example_2.svg)

Result:
FF17 fails to apply transparency and a part of the SVG image is covered by a green overlay.

Mozregression range:
m-c
good=2012-08-05
bad=2012-08-06
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9453cf029b72&tochange=c8d94fe7506a

Suspected bug:
Bug 655877 - SVG text should use CSS text frames to gain support for various text layout features

Reporter: http://forums.mozillazine.org/viewtopic.php?p=12232157#p12232157
Blocks: svgtext
Keywords: regression, testcase
Blocks: 619964
No longer blocks: svgtext
Attached patch patchSplinter Review
I wonder how I managed to delete that?
Assignee: nobody → longsonr
Attachment #655963 - Flags: review?(jwatt)
OS: Windows 7 → All
Hardware: x86_64 → All
the test conditions need an extra space indent. I can do that on checkin.
Summary: Firefox 17 doesn't apply transparency to SVG image open directly in a tab → Firefox 17 fails to respect evenodd fill-rule
Attachment #655963 - Flags: review?(jwatt) → review+
Target Milestone: --- → mozilla18
Should this be a candidate for uplifting to Aurora (17)?
It should. Normally I'd wait till it got to mozilla-central before asking.
https://hg.mozilla.org/mozilla-central/rev/c4ceb6420c60
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 655963 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 619964
User impact if declined: some shapes filled incorrectly
Testing completed (on m-c, etc.): landed on m-c with reftest.
Risk to taking this patch (and alternatives if risky): restores code inadvertently removed when existing function moved. That's about as low risk as you can get given all releases of prior to 16 had have these lines in.
String or UUID changes made by this patch: none.
Attachment #655963 - Flags: approval-mozilla-aurora?
Comment on attachment 655963 [details] [diff] [review]
patch

[Triage Comment]
Low risk fix for a FF17 regression, approving for Aurora.
Attachment #655963 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using the STR from the Description on Firefox 17 beta 3 - the SVG image is properly displayed and it's not covered by a green overlay.

Verified that Firefox 17 beta 3 respects the evenodd fill-rule on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.