Last Comment Bug 786219 - Lack for pdfjs/content/web/images/toolbarButton-fullscreen.png
: Lack for pdfjs/content/web/images/toolbarButton-fullscreen.png
Status: RESOLVED FIXED
[qa-]
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 18
Assigned To: Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
:
:
Mentors:
Depends on:
Blocks: 784718
  Show dependency treegraph
 
Reported: 2012-08-28 05:19 PDT by Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
Modified: 2012-10-16 16:24 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (1.12 KB, patch)
2012-08-28 05:23 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
dtownsend: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-08-28 05:19:32 PDT
At Bug 784718, we update pdf.js to 0.4.11.
But its commit lack for pdfjs/content/web/images/toolbarButton-fullscreen.png.
Comment 1 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-08-28 05:23:47 PDT
Created attachment 655960 [details] [diff] [review]
patch

This patch is for mozilla-central 18.
And also the patch is needed to approval-aurora 17.
Comment 2 Dave Townsend [:mossop] 2012-08-29 05:21:50 PDT
Comment on attachment 655960 [details] [diff] [review]
patch

r=whatever
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-29 08:30:25 PDT
What practical effects does this image being missing have?
Comment 4 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-08-29 09:42:02 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> What practical effects does this image being missing have?

Not showing the full-screen icon in PDF viewer.
It should be shown next to the "Download" icon.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-29 14:04:53 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/acb866bc42c2
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-29 14:06:28 PDT
Comment on attachment 655960 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 784718
User impact if declined: Not showing the full-screen icon in PDF viewer next to the download icon.
Testing completed (on m-c, etc.): Local testing. On inbound.
Risk to taking this patch (and alternatives if risky): Very little.
String or UUID changes made by this patch: None.
Comment 7 Alex Keybl [:akeybl] 2012-08-29 15:43:06 PDT
PDF.js was disabled by default in bug 786012 for FF16/17. What's the motivation for fixing this on Aurora given that?
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-29 17:10:04 PDT
Comment on attachment 655960 [details] [diff] [review]
patch

Some people might want to enable it for testing, or something. Doesn't really hurt to take it for consistency, IMO, since there's no risk.
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-08-29 17:21:19 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/cb69436c3056
Comment 10 Alex Keybl [:akeybl] 2012-08-29 18:40:57 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #8)
> Some people might want to enable it for testing, or something. Doesn't
> really hurt to take it for consistency, IMO, since there's no risk.

We normally don't take fixes for features that are disabled by default, and enabled through about:config. Tinkerers can always get their fix on Nightly. It's mostly a matter of consistency in triage and landings.

Understood that a file addition is obviously low risk though.
Comment 11 Ed Morley [:emorley] 2012-08-30 03:53:16 PDT
https://hg.mozilla.org/mozilla-central/rev/acb866bc42c2

Note You need to log in before you can comment on or make changes to this bug.