horizontal scroll scrolls through history

RESOLVED DUPLICATE of bug 266684

Status

()

RESOLVED DUPLICATE of bug 266684
7 years ago
6 years ago

People

(Reporter: yozh, Unassigned)

Tracking

19 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Horizontal scrolling (with trackpad) scroll through history, when page has no horizontal scrollbar. This is a problem, because I often accidentally scroll horizontally a little while touching trackpad, and filled form is lost.

mousewheel.horizscroll.withnokey.action is set to 0 (in about:config). Actually, all mousewheel.horizscroll set to their defaults.

Firefox 14.0.1, OSX 10.8.1.



Expected results:

Horizontal scrolling should not scroll through the history.

Comment 1

7 years ago
I'm not sure if the following will solve this, but putting it here in case it does.

"For backwards compatibility a hack has been inserted that creates fake invisible scrollbars so that the Trackpoint drivers will continue to work."

The following about:config preference:

ui.trackpoint_hack.enabled

needs to be set to 1

Comment 2

7 years ago
An fyi on the preference mentioned in comment 0, from Firefox 17 onwards the preference names have changed:
https://wiki.mozilla.org/Gecko:Mouse_Wheel_Scrolling#Preferences_for_customizing_delta_values_and_default_action
(Reporter)

Comment 3

7 years ago
There's no ui.trackpoint_hack.enabled in FF 14 on Mac. There are no preferences with names containing "hack".

Comment 4

7 years ago
Related: bug 266684, bug 282140, bug 643226.
(Reporter)

Comment 5

6 years ago
Same problem in Nightly 19.0a1 (2012-11-08).
(Reporter)

Updated

6 years ago
Version: 14 Branch → 19 Branch
(In reply to Stepan Koltsov from comment #5)
> Same problem in Nightly 19.0a1 (2012-11-08).
Can you provide a link to test?
(Reporter)

Comment 7

6 years ago
@Paul me? I have no idea how to create a test.
(In reply to Stepan Koltsov from comment #0)
> Horizontal scrolling (with trackpad) scroll through history, when page has
> no horizontal scrollbar

What's the page ?
(Reporter)

Comment 9

6 years ago
@Paul

Any page. For instance:

1. Open http://google.com/
2. Search for "Firefox"
3. Click first link, navigate to http://mozilla.org/...
4. Check that page has no horizontal scrollbar
5. Scroll left or right with two fingers on touchpad (direction depends on whether scroll is inverted in OSX)

You will be navigated back to Google's SERP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266684
You need to log in before you can comment on or make changes to this bug.