The default bug view has changed. See this FAQ.

Primary buffer doesn't contain http:// when selecting the URL bar value

NEW
Unassigned

Status

()

Firefox
Location Bar
5 years ago
5 years ago

People

(Reporter: nemo, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I'll preface all my trimurl bugs by saying that the opera method (bug #667271) avoids virtually all the trimurl problems, means that the URL bar is faster (bug #781588) and ensures that users still have some idea that a protocol exists, for pasting URLs places where it matters, like in web forms.  In short, Opera got it right, Chrome got it wrong, Firefox should copy Opera not Chrome :)

But anyway.

Pending reopening of bug #667271 it would be nice if trimurl didn't break stuff.

In this case, if I go to a url such as:
www.nytimes.com/2012/08/26/health/research/with-rise-of-gene-sequencing-ethical-puzzles.html?pagewanted=2&_r=1&ref=general&src=me

(I'm deliberately leaving off http:// 'cause in this case, that's exactly what I got when pasting)

And I decide I want to remove everything following the ?.
I select that portion, hit delete.

I now doubleclick on the rest of the url, which selects and copies to the X buffer.

I then middle click and get:
www.nytimes.com/2012/08/26/health/research/with-rise-of-gene-sequencing-ethical-puzzles.html

Now. Let's say I want to send someone a page from my history.
I hit ctrl-t, and in the new tab, type a few letters into the awesomebar.
I move down the list of suggestions to the one I want and doubleclick in the middle of the text to select it all, then paste.
I get:
www.nytimes.com/2012/08/26/health/research/with-rise-of-gene-sequencing-ethical-puzzles.html?pagewanted=2&_r=1&ref=general&src=me

Now, with the opera approach, any focusing on the URL bar would simply display those letters, and copy/paste would "just work" with no need for complex javascript.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670531
(Reporter)

Comment 2

5 years ago
Um. Pretty sure this one isn't a duplicate, I hope you're familiar w/ what is happening under the surface.

1) Is Linux specific, the X11 clipboard copy using mouse selection.

2) Unlike the 2nd bug I filed (which I guess *is* a duplicate) this one also seems to mess up entire unedited URLs when doubleclicking on them when they fill URL bar after browsing awesomebar.   That does not happen with ctrl-c/ctrl-v

So. Just asking, are you sure? :)

Otherwise, I feel I should undupe it...

Updated

5 years ago
Blocks: 665580
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
Summary: TrimURL fails to copy http:// when doubleclicking on the URL bar → Primary buffer doesn't contain http:// when selecting the URL bar value

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.