Toolbars don't repaint atomically when a window gains/loses focus

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: Stuart Cook, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120828042007

Steps to reproduce:

Open multiple windows and use Cmd+` to toggle between them, or use Cmd+J to open and close the Downloads window.


Actual results:

When either window's toolbar area is repainted to reflect its change in focus state, it repaints in several different sections over time instead of repainting atomically. The effect is similar to a window being painted without double-buffering.


Expected results:

Each window should repaint itself to reflect its new focus state in a single step.
Stuart, could you please try reproducing this issue in safe mode(http://support.mozilla.com/en-US/kb/Safe+Mode)/with a new profile(http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles) and report back whether you still see it or not?
Also, please try with HW acceleration disabled to see if it makes any difference.

Thank you!
(Reporter)

Comment 2

6 years ago
I can confirm that this issue occurs in a fresh profile with no add-ons, with or without hardware acceleration.
(Reporter)

Comment 3

6 years ago
Bisecting nightlies, I have found that this issue does NOT occur in 2012-08-13, but DOES occur in 2012-08-14.
(Reporter)

Comment 4

6 years ago
This issue is still present in current nightlies as of 2012-09-07-03-05-54 (FF 18).
(Reporter)

Updated

6 years ago
Version: 17 Branch → Trunk
Hello Stuart,

I just found your old bug and want to ask you to give us an short update.
after some tests i can't reproduce your problem in actual Firefox 32.
so I'm not sure if it was solved in the meantime.

thank you for the help
Flags: needinfo?(scook0+bugzilla)
(Reporter)

Comment 6

4 years ago
I can no longer reproduce this bug, and I don't remember seeing it for quite some time. So it's probably been solved by other changes.
Flags: needinfo?(scook0+bugzilla)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.