Firefox 15 problem with focus of URL bar and Search bar when any theme but default is used

RESOLVED DUPLICATE of bug 769405

Status

()

Toolkit
Themes
RESOLVED DUPLICATE of bug 769405
6 years ago
6 years ago

People

(Reporter: Dave Pyles, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

I just installed Firefox 15 and there seems to be a problem with getting focus on the URL bar and the Search bar.  When I first start the program with any theme except the default theme (I tried half a dozen different themes), when I click in the URL bar the cursor will not go there so I can't type anything there.


Actual results:

Nothing happens when I click in either the URL Bar or the search bar. (I use a blank page for my home page) If I first load a page from a bookmark and then try to go to another page by
typing in the URL bar everything works fine.

When I try to type in the Search bar the cursor will not go there when
I'm using any theme but the default one.


Expected results:

I should have been able to type a URI in the URL bar or type a search in the search bar.

Comment 1

6 years ago
Could you test with basic troubleshooting steps, please:

1) Try in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) Try with a fresh new profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Are you able to reproduce the issue?
(Reporter)

Comment 2

6 years ago
I tried this with a new profile, and after installing a theme in the new profile, yes, I can reproduce the problem.  Since it requires a theme, any theme other than the default theme, I didn't try it in safe mode.

Comment 3

6 years ago
So it's an issue with the theme, not Firefox.
(Reporter)

Comment 4

6 years ago
It's not an issue with just one theme, it's an issue with any theme that I have installed except the default theme.  I tried this with half a dozen different themes from different theme developers and it is reproducible with all of them.

Comment 5

6 years ago
Could you paste some theme URLs, so we could test, please.
(Reporter)

Comment 6

6 years ago
I tried downloading the full program from the web site and installing it and the problem went away, so it seems to be a problem only with the update.

Here are some URLs
These do not work:
https://addons.mozilla.org/en-US/firefox/addon/nasa-night-launch/
https://addons.mozilla.org/en-US/firefox/addon/ft-deepdark/eula/157613?src=dp-btn-primary
https://addons.mozilla.org/en-US/firefox/addon/lavafox-v1-blue/?src=userprofile

This one works properly:
https://addons.mozilla.org/en-US
Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/18.0 Firefox/18.0

I installed one of the *non working* themes from comment #6 and I was able to type in the URL/search bar. The problem is that when trying to type in the empty bar (e.g.: about:blank for URL, or no previous search) the highlight is very poor (black cursor on a dark background) and the "default" text ("Go to a Website" for URL bar, "Google" for search bar) is not removed when focus is moved on it. Still, you are able to type.

Dave, could you please confirm whether this is the behavior you experience, as well?

Thank you!
(Reporter)

Comment 8

6 years ago
Yes, after installing from the full installer as opposed to the update, that is the behavior I'm experiencing now.  When I installed the program from the update originally, I could not type in those fields at all.

Updated

6 years ago
Component: Untriaged → Themes
Product: Firefox → Toolkit

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769405
You need to log in before you can comment on or make changes to this bug.