Bug 786373 (tegra-294)

tegra-294 problem tracking

RESOLVED FIXED

Status

Infrastructure & Operations
Buildduty
RESOLVED FIXED
6 years ago
17 days ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Details

(Whiteboard: [buildduty][buildslave][capacity][mobile], URL)

(Reporter)

Description

6 years ago
Didn't come back from a PDU reboot.
back up after recovery
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Whiteboard: [buildduty][buildslave][capacity][mobile]
Component: Release Engineering → Release Engineering: Machine Management
OS: All → Android
QA Contact: release → armenzg
Hardware: All → ARM
Failing to update the SUTAgent (failing to push it to device's sdcard), please reimage+swap sdcard
Status: RESOLVED → REOPENED
Depends on: 817995
Resolution: FIXED → ---

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
No jobs taken on this device for >= 7 weeks
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(mass change: filter on tegraCallek02reboot2013)

I just rebooted this device, hoping that many of the ones I'm doing tonight come back automatically. I'll check back in tomorrow to see if it did, if it does not I'll triage next step manually on a per-device basis.

---
Command I used (with a manual patch to the fabric script to allow this command)

(fabric)[jwood@dev-master01 fabric]$  python manage_foopies.py -j15 -f devices.json `for i in 021 032 036 039 046  048 061 064 066 067 071 074 079 081 082 083 084 088 093 104 106 108 115 116 118 129 152 154 164 168 169 174 179 182 184 187 189 200 207 217 223 228 234 248 255 264 270 277 285 290 294 295 297 298 300 302 304 305 306 307 308 309 310 311 312 314 315 316 319 320 321 322 323 324 325 326 328 329 330 331 332 333 335 336 337 338 339 340 341 342 343 345 346 347 348 349 350 354 355 356 358 359 360 361 362 363 364 365 367 368 369; do echo '-D' tegra-$i; done` reboot_tegra

The command does the reboot, one-at-a-time from the foopy the device is connected from. with one ssh connection per foopy

Updated

5 years ago
Depends on: 838687
had to stop and start clientproxy to make this happy again.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

5 years ago
agent check failing, try pdu reboot
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 7

5 years ago
in prodcution, but failing agent check for some reason. filed bug 890340 on that.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
It's throwing up failures like the below on xpcshell (this isn't the first I've seen). Is the clock set wrong or something? Disabled in slavealloc.
https://tbpl.mozilla.org/php/getParsedLog.php?id=32232378&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #8)
> It's throwing up failures like the below on xpcshell (this isn't the first
> I've seen). Is the clock set wrong or something? Disabled in slavealloc.
> https://tbpl.mozilla.org/php/getParsedLog.php?id=32232378&tree=B2g-Inbound

I don't know how to answer this question.
Flags: needinfo?(bugspam.Callek)
Hmm, seems like the logs for such failures are too old and have been rm.

Not sure how to diagnose this? Callek, would you know what errors Ryan saw or know how we can reproduce this (eg: test it in production or fire a few xpcshell tests at it from a dev master)
The last 75 or so jobs are mostly green, but this tegra seems to struggle especially with robocop-2 and mochitest-8 jobs.
robocop-2 failure:

MochitestServer : launching [u'/builds/tegra-294/test/build/hostutils/bin/xpcshell', '-g', '/builds/tegra-294/test/build/hostutils/xre', '-v', '170', '-f', '/builds/tegra-294/test/build/hostutils/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpDb06bU'; const _SERVER_PORT = '30294'; const _SERVER_ADDR = '10.26.84.25'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', './server.js']
runtests.py | Server pid: 22188
runtests.py | Running tests: start.

Robocop process name: org.mozilla.fennec
INFO | automation.py | Application pid: 0
0 INFO SimpleTest START
1 INFO TEST-START | testPromptGridInput
2 INFO TEST-PASS | testPromptGridInput | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
EventExpecter: no longer listening for Gecko:Ready
3 INFO TEST-PASS | testPromptGridInput | Loaded blank page - page title match
4 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 1
5 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 2
6 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 3
7 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 4
8 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 5
9 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 6
10 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 7
11 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 8
12 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 9
13 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 10
14 INFO TEST-PASS | testPromptGridInput | Found grid item - Icon 11
waitForText timeout on PASS
15 INFO TEST-UNEXPECTED-FAIL | testPromptGridInput | test passed - PASS
Exception caught during test!
junit.framework.AssertionFailedError: 15 INFO TEST-UNEXPECTED-FAIL | testPromptGridInput | test passed - PASS
	at junit.framework.Assert.fail(Assert.java:47)
	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:110)
	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:139)
	at org.mozilla.gecko.tests.testPromptGridInput.testPromptGridInput(testPromptGridInput.java:43)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:145)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
16 INFO TEST-UNEXPECTED-FAIL | testPromptGridInput | Exception caught - junit.framework.AssertionFailedError: 15 INFO TEST-UNEXPECTED-FAIL | testPromptGridInput | test passed - PASS
17 INFO TEST-END | testPromptGridInput | finished in 51148ms
18 INFO TEST-START | Shutdown
19 INFO Passed: 13
20 INFO Failed: 2
21 INFO Todo: 0
22 INFO SimpleTest FINISHED
INFO | automation.py | Application ran for: 0:00:54.130150
INFO | zombiecheck | Reading PID log: /tmp/tmp3wGYc2pidlog
/data/anr/traces.txt not found
WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
runtests.py | Running tests: end.
mochitest-8 failure:

MochitestServer : launching [u'/builds/tegra-294/test/build/hostutils/bin/xpcshell', '-g', '/builds/tegra-294/test/build/hostutils/xre', '-v', '170', '-f', '/builds/tegra-294/test/build/hostutils/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpcpjGc2'; const _SERVER_PORT = '30294'; const _SERVER_ADDR = '10.26.84.25'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', './server.js']
runtests.py | Server pid: 24324
runtests.py | Running tests: start.

INFO | automation.py | Application pid: 1900
0 INFO Running tests 2217-2533/2533
1 INFO SimpleTest START
...
3677 INFO TEST-INFO | /tests/uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | run_next_test called, gCounter = -1
3678 INFO TEST-INFO | /tests/uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | Loading test 0 (.test) from unsafeBidiFileName.sjs?name=%C3%A2%C2%80%C2%AA.test

TEST-UNEXPECTED-FAIL | /tests/uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | application timed out after 330 seconds with no output
INFO | automation.py | Application ran for: 0:10:46.856997
INFO | zombiecheck | Reading PID log: /tmp/tmpCKR_gkpidlog
/data/anr/traces.txt not found
WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
runtests.py | Running tests: end.
Huh. robocop-2 started passing today. Haven't seen any new mochitest-8 results since early this morning.
(Reporter)

Updated

4 years ago
Flags: needinfo?(bugspam.Callek)
Taking jobs again
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED

Updated

17 days ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.