fonts where asigned to a wrong width, which makes them overlaping each other.

RESOLVED DUPLICATE of bug 63831

Status

()

--
major
RESOLVED DUPLICATE of bug 63831
18 years ago
17 years ago

People

(Reporter: thomas.scheffler, Assigned: bstell)

Tracking

({relnote})

Trunk
mozilla0.9.3
x86
Linux
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This problem occurs for me, if a text is rendered in parts with different sizes
and weight such as on the result page of the google page, or if you watch a
table where cellpadding and cellspacing is small enough. The problem is that
some words overdraw others which wasn't obviously meant. This problem first
occurs since I installed mandrake 8.0 but maybe it visible on other
distributions too. I'm using the nvidia driver 769 for my Geforce DDR an the
resolution is set to 1280x1024 (75 dpi). With the latest build (20010502) this
problem still exists.
(Reporter)

Comment 1

18 years ago
in the last nightly build (20010530) the problem still exist.
My configuration is:
NVIDIA GeForce DDR with nvidia's driver ver 1.0.1251
Mandrake 8.0
XFree 4.0.3

This is an extreme ugly bug.

Comment 2

17 years ago
It's still there in CVS Jun 7, 8 am. I also started seeing this bug with
Mandrake 8.0. It seems to occur with Arial-type fonts.

Comment 3

17 years ago
I am also seeing this bug, also in Linux-Mandrake 8.0.  I have tried a variety
of things to fix this and nothing has helped.  I've imported fonts from Windows
to see if those render more properly - to no avail.  I'm not sure if it is
restricted to arial type fonts, either - the overlapping of table borders seems
to be regardless of font type.

I do not see this bug in nightly builds on MacOS 9.1 or Win98, so it appears
restricted to Linux, probably LM 8.0.  From what I can determine of the font
subsystem, it is using:

XFree86-4.0.3
XFree86-xfs-4.0.3

This is a severe problem for users of Mandrake Linux.  I am not entirely
positive that ALL users of LM are affected, but since I've been utterly unable
to fix the problem, I assume most are.  It may not be a problem in Mozilla
necessarily, but certainly a compatibility issue.  Also note: this problem does
not appear in Netscape Communicator 4.7x using the same fonts on the same system
- so it is not ENTIRELY a problem for LM 8.0.

Comment 4

17 years ago
Temporary (?) fix found - 

In Mozilla, go to Edit~Preferences...~Appearance~Fonts and deselect "Allow
documents to use other fonts".  This fixed the problem right away for me (I went
straight to Google and checked).  Here's what I don't know: why?

This solution came from alt.os.linux.mandrake - a kind soul had the same problem.

Regards - Brice.

Comment 5

17 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
I think it is a bug in drakfont-0.58-13.1mdk. (I will file a bugreport in their
bugzilla, if there is alread one) This bug appeared first after I updated from
drakfont-0.58-11mdk to this version.

To fix it, do the following:
Replace drakfont-0.58-13.1mdk by the old drakfont-0.58-11mdk with
rpm -Uvh --force drakfont-0.58-11mdk.i586.rpm

Remove the fonts installed with drakfont in /usr/X11R6/lib/X11/fonts/drakfont
(you can create a backup of this directory if you like) with
drakfont -k

(Might be necessary: 
Restart xfs with 
/etc/rc.d/init.d/xfs stop
/etc/rc.d/init.d/xfs start 
)

Add the fonts again with drakfont.

Restart mozilla.

Now a pages are displayed correctly again.

Comment 7

17 years ago
Reassigning to ftang.
Assignee: karnaze → ftang

Comment 8

17 years ago
It seems we need to address this in the release not. Move to bstell and target 
moz1.0 for release note. 
Assignee: ftang → bstell
Keywords: relnote
Target Milestone: --- → mozilla1.0

Comment 9

17 years ago
FWIW, I'm using drakfont-0.58-11mdk and I still see the problem. Deselecting the
"Use other fonts" options works, though, but I find that the documents look much
less interesting.

Comment 10

17 years ago
In fact I now also think that it's not the version of drakfont but the windows
fonts themselves. I got rid of the bug be removing my windows fonts on the linux
side with drakfont -k and reinstall them again from my windows partition. A
guess: Before I had reinstalled the 16 bit versions of the fonts which can be
downloaded from the microsoft website were (also) installed. Now I have
installed only the 32bit versions. At the moment I do not have the link to the
corresponding microsoft site, but I can search for it.

Comment 11

17 years ago
Yes, I'd like that. My fonts were taken from my Win2K installation. Aren't those
supposed to be 32bit fonts?

Comment 12

17 years ago
Here is a list of the fonts which work:
AriBlk.ttf    Georgiaz.ttf  Verdana.ttf   arial.ttf    courbi.ttf   times.ttf
Comic.ttf     Impact.ttf    Verdanab.ttf  arialbd.ttf  couri.ttf    timesbd.ttf
ComicBD.ttf   Trebuc.ttf    Verdanai.ttf  arialbi.ttf  fonts.dir    timesbi.ttf
Georgia.ttf   Trebucbd.ttf  Verdanaz.ttf  ariali.ttf   l_10646.ttf  timesi.ttf
Georgiab.ttf  Trebucbi.ttf  Webdings.ttf  cour.ttf     lucon.ttf
Georgiai.ttf  Trebucit.ttf  andalemo.ttf  courbd.ttf   symbol.ttf

This is a list of the old fonts, which didn't work. 
ARIAL.ttf     Georgiaz.ttf  Webdings.ttf  courbi.ttf    starmath.ttf
ARIALBD.ttf   Impact.ttf    andalemo.ttf  couri.ttf     symbol.ttf
ARIALBI.ttf   TIMES.ttf     arial.ttf     fonts.dir     tahoma.ttf
ARIALI.ttf    TIMESBD.ttf   arialbd.ttf   helb____.ttf  timb____.ttf
AriBlk.ttf    TIMESBI.ttf   arialbi.ttf   helbi___.ttf  timbi___.ttf
COUR.ttf      TIMESI.ttf    ariali.ttf    helcb___.ttf  times.ttf
COURBD.ttf    Trebuc.ttf    arib____.ttf  helcbi__.ttf  timesbd.ttf
COURBI.ttf    Trebucbd.ttf  arir____.ttf  helci___.ttf  timesbi.ttf
COURI.ttf     Trebucbi.ttf  chvor___.ttf  helcr___.ttf  timesi.ttf
Comic.ttf     Trebucit.ttf  chvr____.ttf  heli____.ttf  timi____.ttf
ComicBD.ttf   Verdana.ttf   cogb____.ttf  helr____.ttf  timr____.ttf
Georgia.ttf   Verdanab.ttf  cogr____.ttf  l_10646.ttf   wingding.ttf
Georgiab.ttf  Verdanai.ttf  cour.ttf      lucon.ttf
Georgiai.ttf  Verdanaz.ttf  courbd.ttf    starbats.ttf

I guess, one (or more) of them is somehow broken. When I reinstall all these
fonts, the same error reappears.
(Assignee)

Comment 13

17 years ago
is this the same bug as 59915?

Comment 14

17 years ago
Yes, it would certainly appear that this bug is a duplicate of 59915 (though
approached slightly differently).

Comment 15

17 years ago
*** Bug 59915 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
I have seen these problems with RedHat 6.2 and XFree86 from CVS
(tested all the 4.0.x versions).

The page I have most often seen problems with is:

http://www.zdnet.com

Comment 17

17 years ago
What's staus on this: I'm seeing this on www.mozillazine.org quite often :(
(Assignee)

Comment 18

17 years ago
It's on my list of things I to look (near the top).

I'd like to fix it but with the current state of checkin restrictions
(fix must be very low risk) from now till moz 1.0 I will not know if a fix
is possible before then.
*** Bug 88219 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

17 years ago
just for the record:

I am very interested in this as I really want to move the Linux Moz
client to newer outline font technology.

I just got a new system to run Redhat 7.1 on and as soon as it is up
an fully running I will look at this bug.

Comment 21

17 years ago
On that note - I'd love to help out with getting Mozilla to use rendered fonts
(I assume that's what you referred to?).  I have a XF4.1 setup that works with
rendered fonts and I can help test things or whatever else you might have me do.
 I've been wanting to get involved in Moz for a while, but haven't found an area
that I'm really interested in :).  This is definitely one of those areas. 
Getting Moz on Linux to look as nice as Moz on my Mac (OS 9.1) w/ ATM rendered
fonts would be seriously sweet.

Sign me up.

Comment 22

17 years ago
I am getting this too. I also  have Mandrake 8 but did not have a problem until
downloading Mozilla 0.9.2

Fonts overlap each other and so do frames.  For example I was looking at the
story about John Le Carre in the Sunday Times (www.sunday-times.co.uk) and the
picture of his father was cutting off the ends of all of the adjacent words.  I
assume that this is a tweak to the rendering engine but I don't have a clue really!

Comment 23

17 years ago
*** Bug 87886 has been marked as a duplicate of this bug. ***

Comment 24

17 years ago
Marking mostfreq at 10 dups.
Keywords: mostfreq
(Assignee)

Comment 25

17 years ago
Steven: 

1) If you use a 0.9.1 build does the problem go away?

2) Do you have true type fonts loaded on your system?

Comment 26

17 years ago
This bug is a problem for me too (I'm using Mandrake 8, Mozilla 0.9.1).  It only
seems to happen with TrueType fonts, though.  I have not tried any of the
mentioned workarounds, nor Mozilla 0.9.2.
(Assignee)

Comment 27

17 years ago
Created attachment 41520 [details]
A very simple testcase specifying a freetype-arial-10646-1 font
(Assignee)

Comment 28

17 years ago
Created attachment 41521 [details]
image of attachment 78643 [details] [diff] [review] on Redhat 6.2 system showing overlap
(Assignee)

Comment 29

17 years ago
I got the freetype font from bug 63831:

> ------- Additional Comments From Stanislav Brabec 2001-04-05 15:37 -------
> ...
> I have placed few problematic fonts at
> ftp://ftp.penguin.cz/pub/users/utx/temp/X11_winfonts.tar.gz
> You can download them, add then to fontpath, restart mozilla
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.3
(Assignee)

Comment 30

17 years ago
can one of the developers who see this problem try this fix for bug 63831
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=41534
and see if it also fixes this bug?

thanks
(Assignee)

Comment 31

17 years ago
Jacek: what are the other bug numbers?

Comment 32

17 years ago
The problem is clearly some difference of 16 and 32 bit fonts, I upgraded main
truetype fonts to current versions (should be 32-bit...) with a TT-fetching
script that SuSE provide in their distribution (so that all their users can get
to use TT fonts, fetching directly from M$) - and now Moz displays everything OK!
(Assignee)

Comment 33

17 years ago
the fix for bug 63831 (now checked in) should fix this.

*** This bug has been marked as a duplicate of 63831 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.