Add Valgrind instrumentation to invalidate patched JIT code. (never forget smc-check)

RESOLVED DUPLICATE of bug 598263

Status

()

RESOLVED DUPLICATE of bug 598263
6 years ago
6 years ago

People

(Reporter: nbp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Valgrind provide a macro VALGRIND_DISCARD_TRANSLATIONS to inform valgrind process that a range of code has been invalidated / patched.  Instrumenting the code will prevent any miss-leading valgrind errors.

[1] http://valgrind.org/docs/manual/manual-core-adv.html
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598263
You need to log in before you can comment on or make changes to this bug.