Closed Bug 786534 Opened 9 years ago Closed 8 years ago

Remove export target from xpcom/glue Makefiles

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 865673

People

(Reporter: gps, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

Various Makefiles under xpcom/glue have export:: targets which do a simple install. These can be rewritten using the generic install rule.

Attached is that patch. I don't pretend to understand why these Makefiles are install cpp files into the object directory. That seems wrong to me. But, that's another bug, I reckon.

I don't believe this breaks the dependency chain anywhere because, well, I don't think there is a dependency chain other than the order of operations in rules.mk. The install rule runs before the compiler, so we should be good.

Try at http://tbpl.mozilla.org/?tree=Try&rev=8aece2a66125
Attachment #656303 - Flags: review?(khuey)
I probably should have mentioned that the Try build failed on Windows. Oh, build system.
Depends on: 888016
Depends on: 899868
Depends on: 900974
Fixed by Bug 865673...?
Flags: needinfo?
Yep
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 865673
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.