Closed Bug 786542 Opened 7 years ago Closed 7 years ago

Remove LL_CMP usages

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 792581

People

(Reporter: m_kato, Unassigned)

References

()

Details

(Whiteboard: [mentor=ehsan][lang=c++])

See bug 783185 (this is under review).  LL_CMP can cause strength bugs.

LL_CMP was that compiler doesn't support 64-bit integer such as int64_t, but current Gecko code requires compiler supports it.

So we should remove LL_CMP and replace with simple condition operator.
Component: Build Config → General
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [mentor=ehsan][lang=c++]
Unless I'm mistaken, I think bug 792581 covers this bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 792581
(In reply to comment #1)
> Unless I'm mistaken, I think bug 792581 covers this bug.

Correct!
You need to log in before you can comment on or make changes to this bug.