Javascript Type error: Can't access dead object when closing a tab in the background. Using dragupload with Firefox 15.0

RESOLVED WONTFIX

Status

Tech Evangelism
Add-ons
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: itsthewoo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

Closed background tab. It does not matter if you use the assigned mousebutton shortcut or the context menu. This only occurs when TabMix Plus v.0.4.0.3 is used.


Actual results:

Javascript error window pops up and returns after closing. Unable to put the error window in the background.


Expected results:

No error window.

Comment 1

5 years ago
That sounds like Tab Mix Plus is trying to access a window object after its tab has been closed (and the window object force destroyed). Firefox cuts all links to this object[1] when a tab is closed to fix a VERY common memory leak in extensions[2].

Try reporting/see if its already reported in there forum[3].

[1] http://blog.kylehuey.com/post/21892343371/fixing-the-memory-leak
[2] http://blog.mozilla.org/nnethercote/2012/07/19/firefox-15-plugs-the-add-on-leaks/
[3] http://tmp.garyr.net/forum/viewforum.php?f=2&start=15

Updated

5 years ago
Blocks: 695480
Component: Untriaged → Add-ons
Product: Firefox → Tech Evangelism
Whiteboard: [Memshrink]
Version: 15 Branch → unspecified
(Reporter)

Comment 2

5 years ago
I don't know if I didn't recreate it properly before, but the error is now occurring even with TabMix Plus disabled.
Can you please paste the full error message? It could have some hints as to where the error is happening.
(Reporter)

Comment 4

5 years ago
It says exactly what the title says it says. "TypeError: can't access dead object."

Tried disabling Session Manager as well. Error is still coming up.
(Reporter)

Comment 5

5 years ago
It started doing it even when tabs weren't in the background. I rolled back to 14.01, and I am not having the issue anymore.

Comment 6

5 years ago
Similar error since upgrading from SeaMonkey 2.11 to 2.12, using Tab-Extensions Duplicate Tab and Tab Clicking Options (http://twanno.mozdev.org/).

It's not happening always when closing a tab, but when it is happening the error pops up every second and you are unable to use the browser, only a restart prevents further error-messages.
TabMix Plus will need to update for the changes.
Whiteboard: [Memshrink]
(Reporter)

Comment 8

5 years ago
I disabled TabMix Plus and it still happened, albeit not immediately.
What other add-ons do you have installed? Can you post the contents of about:support?
(Reporter)

Comment 10

5 years ago
Created attachment 659924 [details]
about:support w/ addons
(Reporter)

Comment 11

5 years ago
I did a legitimate add-on isolation, and it looks like it's actually being caused by dragupload. I have disabled it in 15.01 with all other add-ons (including tab mix plus), and am no longer experiencing problems. I will update if otherwise.
Thanks for the update.  You might like to inform the author of dragupload.

I seem to remember something about TabMix Plus being easily broken by other add-ons -- Kris, do you know about this?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

5 years ago
Looks like dragupload is no longer supported (the URL is no longer available). The reviews on the add-ons download portal indicate the problem that I reported here.
It doesn't sound like this is fixed. Maybe wontfix?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Summary: Javascript Type error: Can't access dead object when closing a tab in the background. Using TabMix Plus 0.4.0.3 with Firefox 15.0 → Javascript Type error: Can't access dead object when closing a tab in the background. Using dragupload with Firefox 15.0
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Comment 15

5 years ago
I can confirm that after disabling dragupload-extension in SeaMonkey the error does not occur again so far.
Yes, the add-on hasn't been updated since June of last year. I'll mark it incompatible with Firefox 15 and above, to avoid confusion.
TabMix Plus is a common cause of incompatibilities, yes. It modifies a lot of tab APIs (mostly by string substitution and eval), so it's hard to play nice with it, but it's popular enough that most add-ons make special considerations.

Comment 18

5 years ago
I think its negligent to say its a "common cause of incompatibilities" when you do not have data backing that statement up.
You need to log in before you can comment on or make changes to this bug.