When content ratings are removed, remove the unrated game from Brazil

VERIFIED FIXED in 2013-10-21

Status

Marketplace
Developer Pages
P2
trivial
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: krupa, Assigned: cvan)

Tracking

2013-10-21
Points:
---

Details

(Whiteboard: p=1, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 656505 [details]
screenshot

steps to reproduce:
1. Pick an app which has content rating and is listed for Brazil.
2. Go to the 'Edit Listing' page for that app- https://marketplace-dev.allizom.org/developers/app/add-on-builder/edit
3. Deselect the content rating and save changes

expected behavior:
When content rating is removed, the app gets removed from Brazil.

observed behavior:
We retain the app in Brazil even when the content rating is removed. See screenshot.
(Assignee)

Comment 1

6 years ago
This seems like something the admin should do when he/she removes the Brazilian content rating.
I assume we're only talking about games.  Yeah, we should fix this bug, but it's not something that is in this milestone.
Priority: -- → P4
Target Milestone: 2012-08-30 → ---
To summarize what this bug is for:

If an app is in the Games category and does not have a Content Rating[1] from the DJCTQ (id=0) then it should not show up in the Brazilian store.
Assignee: nobody → xwraithanx
Priority: P4 → P2
Target Milestone: --- → 2012-11-08
Target Milestone: 2012-11-08 → 2012-11-15
Target Milestone: 2012-11-15 → 2012-11-22
(Assignee)

Comment 4

6 years ago
This is super trivial.
Assignee: xwraithanx → nobody
Severity: normal → trivial
Whiteboard: p=1
Target Milestone: 2012-11-22 → ---
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla/zamboni/commit/35b8691
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-07-25

Comment 6

5 years ago
Issue is still reproducing in https://marketplace-dev.allizom.org/developers/app/add-on-builder/edit on FF25 (Win 7).
Please see screencast http://screencast.com/t/8PqVuVx4eHM4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

5 years ago
(In reply to Iulian Timis from comment #6)
> Issue is still reproducing in
> https://marketplace-dev.allizom.org/developers/app/add-on-builder/edit on
> FF25 (Win 7).
> Please see screencast http://screencast.com/t/8PqVuVx4eHM4

http://f.cl.ly/items/1L1D0O0I1T1o1e3Z1O3y/Screen%20Shot%202013-07-23%20at%203.24.51%20PM.png

Although not made clear in comment 0, Wil clarified this in comment 3. We should be excluding the game in Brazil only if the an app is a Game and it no longer has a content rating. If it has a content rating, and it's not a game, we should not remove it from Brazil.

Sorry for the confusion!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Summary: When content ratings are removed, remove the app from Brazil → When content ratings are removed, remove the unrated game from Brazil

Comment 8

5 years ago
When the Content Rating is added, Brazil is removed, but after we remove the Content Rating, Brazil is not added back to the countries list.
Please see screencast http://screencast.com/t/eGSOaqnyHOwO
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Target Milestone: 2013-07-25 → 2013-08-08
(Assignee)

Updated

5 years ago
Target Milestone: 2013-08-06 → ---
(Assignee)

Comment 9

5 years ago
(In reply to Iulian Timis from comment #8)
> When the Content Rating is added, Brazil is removed, but after we remove the
> Content Rating, Brazil is not added back to the countries list.
> Please see screencast http://screencast.com/t/eGSOaqnyHOwO

That was by design and separate from the bug filed.
(Assignee)

Comment 10

5 years ago
https://github.com/mozilla/zamboni/commit/78a33b3

(In reply to Iulian Timis from comment #8)
> When the Content Rating is added, Brazil is removed, but after we remove the
> Content Rating, Brazil is not added back to the countries list.
> Please see screencast http://screencast.com/t/eGSOaqnyHOwO

I've addressed this now :)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-10-21

Comment 11

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/ on FF27 (Win 7).
Postfix screencast http://screencast.com/t/tlLstuopl
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.