Typing my email into a persona pop-up on Marketplace is slow to get text to appear

RESOLVED WORKSFORME

Status

Firefox OS
General
P1
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: jedp)

Tracking

({perf})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
Steps:

1. Launch the marketplace app
2. Select the email text field
3. Start typing your email

Expected:

As I type something from the keyboard, the text typed should appear relatively quickly (high response time).

Actual:

The delay time for the text to appear is definitely evident. It takes a few seconds for text to appear sometimes in the email field of the persona pop-up.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
Keywords: perf
Text input seems to work as expected for me.  I'm on a 2012-08-29 nightly.  Can you reliably reproduce?
Whiteboard: [blocked-on-input Jason Smith]
(Reporter)

Comment 2

5 years ago
Just reflashed my device to a clean 8/29 build and started from the STR right from the beginning. I can definitely reproduce this reliably.
Whiteboard: [blocked-on-input Jason Smith]
I can't open the Marketplace app on my device with a clean 8/30 build :)  I can see JST trying the "Dev Marketplace" app and the first few characters typed into the email field are definitely delayed but after 3 or so it seems to be alright.  If the main Marketplace app does this, too, then this should block.

With paint flashing on it's clear that a lot of the login panel is being repainted all the time.
blocking-basecamp: ? → +
Ben, if you're not the right person to investigate here, please re-assign.  Thanks.
Assignee: nobody → benadida
Whiteboard: [WebAPI:P0]

Updated

5 years ago
Priority: -- → P1
Whiteboard: [WebAPI:P0]
Ben, are you the right owner here? If so, any updates and/or eta here?
(In reply to Johnny Stenback (:jst, jst@mozilla.com) from comment #5)
> Ben, are you the right owner here? If so, any updates and/or eta here?

I'm the right person to hand this off to my team :)

Sorry, somehow I missed this bug.

Jed: over to you. This requires the device itself, since I hear this is not reproduced in the desktop build. I'm assuming the issue has to do with device performance vs. our JavaScript.
Assignee: benadida → jparsons
I will investigate.  Anecdotally, I have noticed that text input in the native popup or trusted UI is much more responsive than the persona shim in a separate tab.  Hoping that there's not much more to do here than get the native implementation done :)
Lawrence and I were looking at this just now.  His experience is that this is general text input performance and not Persona-specific.  That being said, there was no lag when he tried it just now on his Unagi with the Dev Marketplace.

Jason, can you still reproduce?  What about text input outside of the Marketplace login?
Flags: needinfo?(jsmith)
QA Contact: jsmith
we've noticed this unagi/otoro difference, too, and have been wondering if we need to target otoro performance. We're not doing anything all that special on that login screen when email address is entered, just a tiny bit of computation.
(Reporter)

Comment 10

5 years ago
John H. and myself re-tested and can't reproduce. Don't know what fixed this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jsmith)
Resolution: --- → WORKSFORME
I'm experiencing this since a couple of weeks on Nexus S. Anyone able to reproduce with recent builds on supported devices ?
You need to log in before you can comment on or make changes to this bug.