Closed Bug 786904 Opened 9 years ago Closed 9 years ago

background image painting issues with HWA disabled

Categories

(Core :: Layout, defect)

17 Branch
x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla18
Tracking Status
firefox17 + verified
firefox18 + verified

People

(Reporter: alice0775, Assigned: karlt)

References

Details

(Keywords: regression, Whiteboard: [fixed in bug 785333])

Attachments

(1 file)

http://hg.mozilla.org/mozilla-central/rev/418955e7c3a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120829030520

This is spun off Bug 776247.

In condition of HWA disabled,
Background image is broken after switching tab.

Resizing of the browser helps.
The following pref also helps.
*set image.mem.min_discard_timeout_ms to bigger number such as 1000000
or
*set image.mem.discardable to false

Steps to reproduce:
 1. Start Firefox with HWA disabled
 2. Open several tabs
 3. Open testcase
 4. Select other tab and wait 10-15sec
 5. Select tab of the testcase 

Actual results:
 Background image is painted gray rectangle

Expected results:
 Background image(sky blue) should be painted properly

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/82b6c5885345
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722190243
Bad:
http://hg.mozilla.org/mozilla-central/rev/d78729026fb9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120723063342
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82b6c5885345&tochange=d78729026fb9



Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9302468f64fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722192842
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a5ee3b2e133a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722200242
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9302468f64fa&tochange=a5ee3b2e133a

In local build:
Last good: 7a98f847bb8e
First bad: d988270c151b

Suspected : Bug 539356
Reproduces with X11 basic layers too (but not GL layers).
OS: Windows 7 → All
Regressed at
http://hg.mozilla.org/integration/mozilla-inbound/rev/d988270c151b
BasicLayers should always retain content.
Fixed on m-c during
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7055bd788274&tochange=a1756976e61d
and subsequently backed out and something similar landed later.
Depends on: 785333
Bug 785333 is fixed on Aurora / Firefox 17 too now and this is no longer demonstrating there.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in bug 785333]
Target Milestone: --- → mozilla18
Keywords: verifyme
While trying to verify this bug on Firefox 17 beta 3 I noticed that the painting issue is still visible short after switching the tabs. The gray background can still be seen for a second or so. 

I verified this on the builds before the regression appeared and the same behavior is encountered. Is this intended? 

Would you prefer that I open a new bug for this?
(In reply to Karl Tomlinson (:karlt) from comment #4)
> Bug 785333 is fixed on Aurora / Firefox 17 too now and this is no longer
> demonstrating there.

Could you please answer to the questions from Comment 5?
(In reply to Simona B [QA] from comment #5)
> While trying to verify this bug on Firefox 17 beta 3 I noticed that the
> painting issue is still visible short after switching the tabs. The gray
> background can still be seen for a second or so. 
> 
> I verified this on the builds before the regression appeared and the same
> behavior is encountered. Is this intended? 
> 
> Would you prefer that I open a new bug for this?

This may be Bug 676270
(In reply to Alice0775 White from comment #7)
> This may be Bug 676270

Thanks Alice, I believe that as well.

Verified on Firefox 17 beta 5 that the background image is painted properly when following the steps from the description. 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0

Based on Comment 5 and 7, setting tracking flag for Firefox 17 to Verified.
QA Contact: simona.marcu
Following STR from comment 0 I verified this issue and it looks like is no longer reproducible as it wasn't on FF 17 from comment 8 .

Windows 7 x64:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

Ubuntu x32
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

Mac OS 10.7
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

Please somneone with permission set flag for ff18 as verified.
Thanks MairioMi!

Based on Comment 9 setting tracking flag for Firefox 18 to Verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.