Closed Bug 786945 Opened 10 years ago Closed 10 years ago

Cannot set value to <select> element

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: rudyl, Assigned: schien)

References

Details

Attachments

(1 file)

STR
===
 1. Click a <select> element (in UI test app. for example)
 2. Select an option and click [OK].

Expected: the option could be set as the value of the <select>.
Actual result: UI freeze.

Error message
=====
/GeckoConsole( 1430): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "this._messageManager.broadcastAsyncMessage is not a function" {file: "jar:file:///system/b2g/omni.ja!/components/MozKeyboard.js" line: 69}]' when calling method: [nsIB2GKeyboard::setSelectedOption]" {file: "app://system.gaiamobile.org/js/value_selector/value_selector.js" line: 156}]
Should use sendAsyncMessage instead of broadcastAsyncMessage, since MozKeyboard no longer uses nsIMessageBroadcaster.
Assignee: nobody → schien
The codebase I used for testing bug 781438 doesn't grab the API change made in bug 776825. MozKeyboard should use |sendAsyncMessage| since it no longer uses the nsIMessageBroadcaster.
I've tested on the latest hg repo.
Attachment #656781 - Flags: review?(21)
Duplicate of this bug: 787264
blocking-basecamp: --- → ?
Blocking as this is something that will likely happen on webpages as well.
blocking-basecamp: ? → +
Keywords: verifyme
QA Contact: jsmith
https://hg.mozilla.org/mozilla-central/rev/5e338df4b730
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.