Closed Bug 786992 Opened 8 years ago Closed 8 years ago

Initial page from opening a new tab doesn't register as a history entry for that tab

Categories

(Firefox :: Untriaged, defect)

15 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 776167

People

(Reporter: wrpterberg, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

- Open up Firefox
- Open a new blank tab. You should now be on the about:newtab page.
- Visit any website, either by clicking a frequently visited website from the about:newtab page or manually enter a URL in the address bar.


Actual results:

The back button remains blank. Attempting to use it via a hotkey does not work either. You are unable to go back to the about:newtab page in that tab. Firefox acts as if you were never there.


Expected results:

Just like what happens in Firefox 14.x you are able to return to the about:newtab page via the back button or the back button hotkey. The initial page loaded by opening a new 'blank' tab acts as an actual visit and is saved in a tab's history.
Because the default about:newtab page (with the thumbnails) is not a part of the browsing history, like some about pages (about:config e.g.), so it doesn't count as history entry and the back button stays gray.

But if you set about:config > browser.newtab.url = URL (e.g. http://www.google.com/), about:newtab will be counted as history entry.

For me, this bug is wontfix.
Dupe of bug 776167?
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776167
You need to log in before you can comment on or make changes to this bug.