Content of Flash plugin is first displayed upside down

RESOLVED FIXED in Firefox 29

Status

()

Firefox for Android
Plugins
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Ioana Chiorean, Assigned: snorp)

Tracking

({flashplayer})

17 Branch
Firefox 29
ARM
Android
flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 656807 [details]
Screenshot

Build ID: 17.0a2 (2012-08-29) Aurora Channel
Device: Galaxy Nexus 
OS: Android 4.0.4

Steps to reproduce:
1. Open Fennec;Enable Plugins
2. Visit URL http://neave.com/tic-tac-toe and click Let's Play button

Expected result:
- Site works and it is displayed correctly

Actual result:
- Flash content is displayed upside down. After a few seconds it is displayed correctly

Note:
- this works fine on other browsers like Default android and Dolphin
- is not reproducible with latest beta 16.0b1
snorp, do you think this Flash bug is related to (or a dupe of) bug 786248?
Keywords: flashplayer
(In reply to Chris Peterson (:cpeterson) from comment #1)
> snorp, do you think this Flash bug is related to (or a dupe of) bug 786248?

Bug 786248 has to do with video only, so I would say this one is different.
I saw this on my Galaxy nexus when loading https://settings.adobe.com/flashplayer/mobile but the Flash content corrected its orientation when I rotated the device or reloaded the page. Unfortunately, I can not reproduce it again.
Created attachment 662068 [details]
screenshot 2

(In reply to Chris Peterson (:cpeterson) from comment #3)
> I saw this on my Galaxy nexus when loading
> https://settings.adobe.com/flashplayer/mobile but the Flash content
> corrected its orientation when I rotated the device or reloaded the page.
> Unfortunately, I can not reproduce it again.

I was able to reproduce it on the latest Nightly (see attached screenshot)

--
Firefox 18.0a1 (2012-09-17)
Device: Galaxy Note
OS: Android 4.0.4
I also had this happen. STR (starting from a recently-reflashed Galaxy Nexus phone):

1. Go to http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html and download Flash Player 11.1.for Android 4.0 (11.1.115.34)
2. adb install the Flash player apk
3. From the app laucher, select "Flash player settings". This prompted for a browser to open the page with. I selected FF Nightly (today's nightly)
4. Tap on the plugin to start it

And voila, an upside-down settings thing.
Assignee: nobody → snorp
This was fixed with bug 957694.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 957694
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.