Closed Bug 787065 Opened 9 years ago Closed 8 years ago

Firefox button from Settings top-left corner doesn't work on ICS

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox16 affected, firefox17 affected, firefox18 affected, firefox19 verified, fennec+)

VERIFIED FIXED
Firefox 19
Tracking Status
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected
firefox19 --- verified
fennec + ---

People

(Reporter: xti, Assigned: sriram)

References

Details

Attachments

(1 file)

Firefox 18.0a1 (2012-08-30)
Devices: Galaxy Note, Galaxy Nexus
OS: Android 4.0.4

Steps to reproduce:
1. Open Fennec
2. Go to Menu > Settings
3. Tap on Fennec button from the top-left corner

Expected result:
Fennec goes back to the main view after step 3.

Actual result:
The button is not working at all at step 3 on ICS. 

Note:
It works as expected on JB.
Works on Jellybean. Sriram, thoughts?
There is a patch that fixes this in bug 773535. I haven't had time to work on that bug. We should split that piece off.
tracking-fennec: --- → ?
Assignee: nobody → sriram
tracking-fennec: ? → +
Attached patch PatchSplinter Review
I hate android! Documentation says "homeAsUp" will enable setHomeButtonEnabled(). However it doesn't! :(

Tested on ICS and JB -- both works.
Attachment #677596 - Flags: review?(mark.finkle)
Attachment #677596 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/4bb16dfa29b4
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Duplicate of this bug: 808447
The Back button works fine now on ICS. Closing bug as verified fixed on:

Firefox 19.0a1 (2012-11-05)
Device: Galaxy S2
OS: Android 4.0.3
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.