Closed Bug 787068 Opened 10 years ago Closed 10 years ago

Instant Messaging and privacy

Categories

(Thunderbird :: Instant Messaging, enhancement)

15 Branch
x86_64
Windows 7
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: florian.catteau, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Using Gtalk in the Instant Messaging function of Thunderbird V15.


Actual results:

my conversations is saved and I can't delete it. 


Expected results:

I would like ti be able to delete my conversations and a privacy mode in which conversations are not saved (= Privacy Mode of Gtalk).
Severity: normal → enhancement
Summary: Instant Messaging → Instant Messaging and privacy
I'm confused at what you actually want, do you want to disable all local logging of conversations (this is already possible, although I'm not sure the preference is exposed in the UI), or do you want to disable remote logging?

Are you asking to just have this as a setting where it's never done or as a mode where you can disable logging for a session, etc.

Deleting logs isn't supported (I don't think...).
Yes, I would like to disable local logging of conversation. I didn't find the preference? 


(In reply to Patrick Cloke [:clokep] from comment #1)
> I'm confused at what you actually want, do you want to disable all local
> logging of conversations (this is already possible, although I'm not sure
> the preference is exposed in the UI), or do you want to disable remote
> logging?
> 
> Are you asking to just have this as a setting where it's never done or as a
> mode where you can disable logging for a session, etc.
> 
> Deleting logs isn't supported (I don't think...).
(In reply to Florian Catteau from comment #2)
> Yes, I would like to disable local logging of conversation. I didn't find
> the preference? 
It looks like you can change it in about:config, it's called purple.logging.log_chats and purple.logging.log_ims. This preference probably doesn't take effect until a restart.
I know about:config in Firefox but how can I do about:config in Thunderbird ?
Tools > Options > Advanced > "Config Editor..." I believe.
Sounds like BIO bug 274 (possibly something for an add-on?)
I'm going to resolve this as WORKSFORME, I think being able to disable it is what you want. If you want something more complicated (like being able to turn it off for a session or disabling remote logging), we can reopen this.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.