Password manager fails to autofill username/password fields on Cisco login page (old regression)

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Loic, Unassigned)

Tracking

({regression})

2.0 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:

1) Start Firefox with a new profile
2) Open http://www.cisco.com/
3) Click on "Log In" (or open http://www.cisco.com/cgi-bin/login?referer=/en/US/hmpgs/index.html)
4) Enter fake guest username (paulobispo) and password (96TJhTK7) and press "Log in" button
5) Accept to "Remember the password" in Firefox (it's important!)
6) Go back to Cisco's homepage and click on "Log Out" (log out completely)
7) Go back to Cisco's homepage and click on "Log In"

Result:
After step #7 (2nd login attempt), Firefox fails to autofill username and password fields, they stay blank.
If you autocomplete the username field, Firefox fails to autofill the password field.

It worked in the past, bu I don't know if the current behavior is wanted.
Anyway I found a regression since Firefox 3.7a1pre (Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre).

m-c
good=2009-10-06
bad=2009-10-07
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f1ba5c38bb1&tochange=4d5760a4f96f

The changelog is pretty huge, bisecting is needed.

Reporter:
http://forums.mozillazine.org/viewtopic.php?f=9&t=2526905
(Reporter)

Updated

5 years ago
Keywords: regression
Version: 14 Branch → 2.0 Branch
(Reporter)

Updated

5 years ago
Keywords: regressionwindow-wanted
This WFM on the current Cisco login page and since there isn't a testcase here there nothing more we can do here.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.