Sort by rating is broken

VERIFIED FIXED in 2012-10-18

Status

Marketplace
Search
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: cvan)

Tracking

2012-10-18
Points:
---

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 656973 [details]
screenshot

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/search/?price=&cat=&sort=rating
2. Check if the apps are sorted by rating

observed behavior:
Looks like sort=rating is not being honored.
Mine looks a lot different. Did we re-indexing after the db refresh?
(Assignee)

Comment 2

5 years ago
(In reply to Rob Hudson [:robhudson] from comment #1)
> Mine looks a lot different. Did we re-indexing after the db refresh?

I did, yeah. I think the cron's messed up.
(Assignee)

Comment 3

5 years ago
Also note that "1 Ratings" should be "1 Rating"
Assignee: nobody → cvan
Target Milestone: --- → 2012-10-18
(Assignee)

Comment 4

5 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #3)
> Also note that "1 Ratings" should be "1 Rating"

Disregard that.

How old is that screenshot? Because I don't see that anymore (I fixed it in bug 787711). And the design in the screenshot is quite different than it is today.

Still a bug though, yes.
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla/zamboni/commit/164918b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/6d34881

Comment 7

5 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED

Comment 8

5 years ago
Created attachment 672715 [details]
Postfix screenshot

Comment 9

5 years ago
Sort by rating is not working as expected again(Not yet rated apps displayed before rated apps). See attached screenshot.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 10

5 years ago
Created attachment 690850 [details]
Ratings broken again
(Assignee)

Comment 11

5 years ago
Andy fixed our indexing in bug 819486. And this should be fixed going forward. Thanks for catching this!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Verified, thx
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.