Banner preview does not show profile image

VERIFIED FIXED in 1

Status

VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 657012 [details]
missing profile

Creating a new banner does not display the profile photo correctly after selecting the photo checkbox. Instead of the profile image, a grey box displays- see screenshot.
(Reporter)

Comment 1

6 years ago
I repro'd this many times on Firefox 15, but the preview displays correctly on Chrome.
Component: affiliates.mozilla.org → Social Integration

Comment 2

6 years ago
Note the missing profile image is both in the banner and in the upper right in the linking area.

I think this is caused by our old friend CSP, you will need to adjust our policy to allow images from the facebooks.

I will upload the full CSP warning as an image in case you need to add other exceptions or create a blanket exception for image-src.

Comment 3

6 years ago
Created attachment 657897 [details]
CSP warnings, it's long as dialog does not wrap text.
You were correct that is was CSP, although I'm curious how you saw that warning; craigcook and I both tested with Firefox 15 and didn't see any warnings, and it *worked* in Nightly. *sigh*

Fix has been pushed and the profile image seems to be working again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 5

6 years ago
I tested using the native firefox web developer -> error console, if I recall correctly I opened the affiliates frame in a new window without the facebook frame for testing.
(Reporter)

Comment 6

6 years ago
Verified able to preview profile image in the banner using FF 15. NB: the profile image also displays correctly now on the sidebar.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

6 years ago
Blocks: 772284
(Assignee)

Updated

3 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.