Can't get cellular data to work on otoro

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dhylands, Assigned: swu)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:M] [WebAPI:P0])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 657110 [details]
logcat output

I picked up a prepaid Telus SIM with a data add-on.

I tried it in my otoro, and I can't get data to work. I've enabled DEBUG_ALL = true in ril_consts.js and attached the logcat.

Using the same SIM in my SGS2 running Android ICS, everything works as expected.
There's yer problem:

> I/Gecko   (  106): -*- RadioInterfaceLayer: Data call ID: 0, interface name: 

There should be an interface name there. We only ever see that if we reboot Gecko without rebooting the entire phone. Do you have an ICS or GB otoro?
(Assignee)

Comment 2

6 years ago
=========================================================================================
I/Gecko   (  106): RIL Worker: Solicited response for request type 27, token 34, error 0
I/Gecko   (  106): RIL Worker: Handling parcel as REQUEST_SETUP_DATA_CALL
I/Gecko   (  106): -*- RadioInterfaceLayer: Received message from worker: {"status":65535,"suggestedRetryTime":-1,"cid":"0","active":0,"type":"","ifname":"","ipaddr":"","dns":"","gw":"","ip":null,"netmask":null,"broadcast":null,"state":3,"radioTech":1,"apn":"isp.telus.net","user":"","passwd":"","chappap":3,"pdptype":"IP","rilMessageType":"datacallstatechange"}
I/Gecko   (  106): RIL Worker: Next parcel size unknown, going to sleep.
I/Gecko   (  106): -*- RadioInterfaceLayer: Data call ID: 0, interface name: 
=========================================================================================
According to the log, device got an invalid response for REQUEST_SETUP_DATA_CALL.  I was about to file a bug of data call failure after restarting b2g process.

May I know whether your data call setting was enabled before booting device?  Or you turn it on after device booted?
(Reporter)

Comment 3

6 years ago
I have an ICS based otoro, and the "Data Connection" was enabled before booting. The phone has been power cycled several times and even had the battery removed.
(Assignee)

Comment 4

6 years ago
Thank for the clarification, then it's a different bug from restarting b2g process(bug 787366).
On my Otoro, I cannot reproduce the error with power cycle, so I may need your help to get more information on this bug. :)
Could you check that if "Data Connection" was disabled before booting, does data call work if you toggle it on after booting?
(Reporter)

Comment 5

6 years ago
Enabling "Data Connection" after booting behaves the same as having it enabled at boot. In both cases I see exactly one occurrence of the following log:

> I/Gecko   (  106): -*- RadioInterfaceLayer: Data call ID: 0, interface name:

Comment 6

6 years ago
I tried my ICS based otoro and it works as expected.


I/Gecko   (  616): -*- RadioInterfaceLayer: Data call ID: 0, interface name: rmnet0
(Reporter)

Comment 7

6 years ago
which suggests that its a carrier specific problem.

Android on my sgs2 works fine with the same SIM/carrier. I guess I'll have to do a build of B2G for the SGS2 to determine if its a SW problem or a HW problem.

When I do use the SIM under Android, sometimes it shows as H+ and sometimes it shows as 3G. My signal strength is fairly weak (I only get about 1 bar). All of my android devices work fine from the same location though.

I'll have to remember to try again when I'm in town and I can get a stronger signal.

Updated

6 years ago
blocking-basecamp: --- → ?
Whiteboard: [smoke-test-bustage]

Comment 8

6 years ago
I'm also having problems with my SIM card in the Otoro - if you'd like logs from me as well, please direct me to how to collect them. Thanks!
blocking-basecamp: ? → +
(Assignee)

Comment 9

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> I'm also having problems with my SIM card in the Otoro - if you'd like logs
> from me as well, please direct me to how to collect them. Thanks!

To get log, please rebuild gecko by setting DEBUG_ALL = true in ril_consts.js, and get it by "adb logcat".
The recent daily smoke test logs didn't show such issue, could you also try if the Otoro image from daily build server works on your device?  Let's narrow down the problem(Sim card, SW, HW, etc...), thank you!

Updated

6 years ago
Keywords: smoketest
Whiteboard: [smoke-test-bustage]
Shian-Yow, can you take this?
Assignee: nobody → swu
Whiteboard: [WebAPI:P0]
(Assignee)

Comment 11

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> I'm also having problems with my SIM card in the Otoro - if you'd like logs
> from me as well, please direct me to how to collect them. Thanks!

Hi Alex, did you get a chance do collect the log?  It will be very helpful to get more log samples to analysis this issue.  If you need more direction to capture logs, you can ping me (my id is shianyow) on irc.
(In reply to Shian-Yow Wu from comment #11)
> (In reply to Alex Keybl [:akeybl] from comment #8)
> > I'm also having problems with my SIM card in the Otoro - if you'd like logs
> > from me as well, please direct me to how to collect them. Thanks!
> 
> Hi Alex, did you get a chance do collect the log?  It will be very helpful
> to get more log samples to analysis this issue.  If you need more direction
> to capture logs, you can ping me (my id is shianyow) on irc.

Hi Shian - sorry for the delay in response. If you could provide a debug build and instructions on how to flash it (if special), I have adb on my computer and can grab a log. Please email me when the build is available, as I'm currently traveling. Thanks!
(Assignee)

Comment 13

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #12)
> Hi Shian - sorry for the delay in response. If you could provide a debug
> build and instructions on how to flash it (if special), I have adb on my
> computer and can grab a log. Please email me when the build is available, as
> I'm currently traveling. Thanks!

Thank you Alex, hope you enjoy your travel.
Will discuss with you by e-mail.

Comment 14

6 years ago
(In reply to Shian-Yow Wu from comment #13)
> (In reply to Alex Keybl [:akeybl] from comment #12)
> > Hi Shian - sorry for the delay in response. If you could provide a debug
> > build and instructions on how to flash it (if special), I have adb on my
> > computer and can grab a log. Please email me when the build is available, as
> > I'm currently traveling. Thanks!
> 
> Thank you Alex, hope you enjoy your travel.
> Will discuss with you by e-mail.

Hi Shian-Yow, Alex,
May I involve in cc list in your mail discussion? I also want to see the log and hope I can help you if I found any. Thanks.
(Assignee)

Comment 15

6 years ago
(In reply to vliu from comment #14)
> Hi Shian-Yow, Alex,
> May I involve in cc list in your mail discussion? I also want to see the log
> and hope I can help you if I found any. Thanks.

Sure, thanks to Vincent. ;)

Comment 16

6 years ago
This may be obvious so feel free to ignore my comment, but I'm assuming you have gone into APN settings and manually updated the APN for your given network?
(Reporter)

Comment 17

6 years ago
Yep.

I can also confirm that I see the APN settings coming from the carrier in the logcat as well.

If I could get my otoro back to android, then I could try it under android and see if its a problem specific to the otoro or something in the B2G SW.

All of my samsung devices work with the same SIM card.
(Reporter)

Comment 18

6 years ago
Seems to be working now (this comment was sent from my otoro over 3G)
(Assignee)

Comment 19

6 years ago
(In reply to Dave Hylands [:dhylands] from comment #18)
> Seems to be working now (this comment was sent from my otoro over 3G)

That's great.  Do we know what's changed that made 3G working?
(Reporter)

Comment 20

6 years ago
I'm not sure. The last time I tried I forgot to enable Data. This time the UI for APN settings is totally different.

I changed the checkbox from custom to Internet.

I now get an H beside the signal strength (where the Wifi signal strength would be)
(Assignee)

Updated

6 years ago
Whiteboard: [WebAPI:P0] → [LOE:M] [WebAPI:P0]
Glad to see that the new UI helped. :-)
(In reply to Dave Hylands [:dhylands] from comment #18)
> Seems to be working now (this comment was sent from my otoro over 3G)

RESO/WORKSFORME?
(Assignee)

Comment 23

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> I'm also having problems with my SIM card in the Otoro - if you'd like logs
> from me as well, please direct me to how to collect them. Thanks!

Per discussion with Alex, he also got data call worked after manually choosing APN in the settings.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(In reply to Shian-Yow Wu from comment #23)
> (In reply to Alex Keybl [:akeybl] from comment #8)
> > I'm also having problems with my SIM card in the Otoro - if you'd like logs
> > from me as well, please direct me to how to collect them. Thanks!
> 
> Per discussion with Alex, he also got data call worked after manually
> choosing APN in the settings.

Yep, looks good now. Thanks!
You need to log in before you can comment on or make changes to this bug.