gif decoder crashes going to www.red-mercury.com

VERIFIED FIXED

Status

()

Core
ImageLib
--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Paul Chen, Assigned: saari (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Using my own debug mac build from 05/01 and a windows 2001043004 build on win2k,
go to http://www.red-mercury.com/. There is an assertion "###!!! ASSERTION: You
can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file
nsCOMPtr.h, line 652".

That assertion is a result of nsGIFDecoder2.cpp, line 303:
  decoder->mImageFrame->SetFrameDisposalMethod(aDisposal);

On my optimized window build, mozilla go boom, I've sent two talkback reports,
but I have no clue as to how to retrieve those. Mac goes belly up, too. I get an
illegal instruction exception in the metrowerks debugger since the PC is at
0x08. Ooops.

So far, this one has been 100% reproducible.

Comment 1

17 years ago
works for me: Linux 2001050308
(Assignee)

Comment 2

17 years ago
Yeah, I just verified with today's bits, and I fixed this with my checkins
yesterday.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
Verified Fixed Win XP build 2001120303, Linux build 2001120308 and Mac OS X
build 2001120308
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.