Closed Bug 787300 Opened 9 years ago Closed 9 years ago

viewmanager.refresh-driver-painting.enabled false: invalidation failure switching from tab with windowed plugin

Categories

(Core :: Layout, defect)

17 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox17 + verified

People

(Reporter: karlt, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Load about:config in one tab.
   (Most pages should reproduce, but new tab and about:blank don't.)
2. Open a second tab and load
   http://www.communitymx.com/content/source/E5141/wmodenone.htm
   (Any page with a windowed plugin seems to reproduce.)
3. Switch back to first tab.

Results:
Content of first tab is only shown where the plugin was in the second tab.
The rest of the window including chrome is not updated.
When showing the plugin tab; covering the window with another window and uncovering (with no window manager compositing) demonstrates failure to paint outside the plugin until focus-in causes a complete repaint.
This was due to having viewmanager.refresh-driver-painting.enabled set to false.

I notice that also causes failure to redisplay about:config or new tab when increasing the size of the window, while the mouse button is still down (dragging).
Assignee: karlt → nobody
Summary: invalidation failure switching from tab with windowed plugin → viewmanager.refresh-driver-painting.enabled false: invalidation failure switching from tab with windowed plugin
Blocks: 786978
This fixes everything that I can reproduce locally, and I covers every potential change that I found when reviewing the diffs.

Karl, can you please test if this fixes the problem you saw?
Attachment #659971 - Flags: review?(roc)
Yes, the PresShell change fixed the issues I reported here, thanks.
Version: 18 Branch → 17 Branch
https://hg.mozilla.org/mozilla-central/rev/2bbc276ffd2a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Comment on attachment 659971 [details] [diff] [review]
Fix bugs with refresh-painting-enabled == false

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 539356
User impact if declined: Required to land bug 786978 on aurora, which has approval.
Testing completed (on m-c, etc.): Landed on m-c, tryserver.
Risk to taking this patch (and alternatives if risky): Low risk, this just reverts the code to what it was previously.
String or UUID changes made by this patch: None
Attachment #659971 - Flags: approval-mozilla-aurora?
Tracking for 17.
Approving it for aurora as it seems a low risk patch and is required for bug 786978
Attachment #659971 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0

Marking as verified with 17 beta 1 on Ubuntu. No problems with viewmanager.refresh-driver-painting.enabled set to false. Loaded a few other flash content sites and didn't spot any issues.
You need to log in before you can comment on or make changes to this bug.