Double-tapping to zoom in and doing it again to zoom out doesn't set the view to the former position

VERIFIED WONTFIX

Status

()

Firefox for Android
Toolbar
VERIFIED WONTFIX
5 years ago
5 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Firefox Mobile Nightly 20120831

Double-tapping to zoom in and doing it again to zoom out doesn't set the view to the former position.

1. Open http://www.computerbase.de/forum/showthread.php?p=12610187#post12610187 in portrait mode.
2. It's a forum, double-tap the content of reply.
3. Double-tap it again.

Actual result:
The view has been moved to the right compared with the initial view given after loading the page.

The page is extended to the right because of the signature "---------..." in comment 9.
This is expected behaviour; we try to zoom out all the way to show the whole page width, but without violating the zoom constraints (the page has a meta-viewport tag with minimum-scale=0.25). Since we cannot do that, we zoom out as much as we can and center the viewport. Trying to fix the behaviour for this specific site will probably break other sites.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.