Can't build .i files on Windows

RESOLVED DUPLICATE of bug 585011

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 585011
5 years ago
4 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
$ pymake SkBitmap.i
make.py[0]: Entering directory 'c:\mozilla-central\obj-i686-pc-mingw32\gfx\skia'

c:\mozilla-central\config\rules.mk:1019:0:native command 'cl InvokeClWithDepende
ncyGeneration cl -C -E -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrappers  -DSK_A32_S
HIFT=24 -DSK_R32_SHIFT=16 -DSK_G32_SHIFT=8 -DSK_B32_SHIFT=0 -DUSE_SKIA -DSKIA_IM
PLEMENTATION -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPT
C_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES
  -Ic:/mozilla-central/gfx/skia/include/core -Ic:/mozilla-central/gfx/skia/inclu
de/config -Ic:/mozilla-central/gfx/skia/include/ports -Ic:/mozilla-central/gfx/s
kia/src/core -Ic:/mozilla-central/gfx/skia/include/images -Ic:/mozilla-central/g
fx/skia/include/utils -Ic:/mozilla-central/gfx/skia/include/utils/mac -Ic:/mozil
la-central/gfx/skia/include/utils/win -Ic:/mozilla-central/gfx/skia/include/view
s -Ic:/mozilla-central/gfx/skia/include/effects -Ic:/mozilla-central/gfx/skia/sr
c/utils -Ic:/mozilla-central/gfx/skia/src/sfnt  -Ic:/mozilla-central/gfx/skia -I
. -I../../dist/include  -Ic:/mozilla-central/obj-i686-pc-mingw32/dist/include/ns
pr -Ic:/mozilla-central/obj-i686-pc-mingw32/dist/include/nss        -TP -nologo
-W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -GR-  -DDEBUG -D_DEBUG -DTRACING -Zi -O
y- -MDd           -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT c:/mo
zilla-central/gfx/skia/src/core/SkBitmap.cpp > SkBitmap.i': shell metacharacter
'>' in command line

Comment 1

5 years ago
So I just did this on Windows again, and it seemed to work for me, but I had previously seen the exact thing that Joe saw.  Not changing the status of bug for now to give the people in the know a chance to comment.
This was fixed by the backout of bug 585011
Blocks: 585011

Comment 3

4 years ago
Resolved per comment #2.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585011
You need to log in before you can comment on or make changes to this bug.