Events that span two or more days are shown incorrect in print output (only shown on first day and with wrong time)

RESOLVED FIXED in 1.8

Status

Calendar
Printing
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Stefan Sitter, Assigned: Stefan Sitter)

Tracking

({regression})

Lightning 1.7
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
An event that spans two or more days (e.g. 2012-08-30 20:00 to 2012-09-02 12:00) is shown incorrect in "Monthly Grid" and "Weekly Planner" print output.

Actual results:
Event is only shown on 2012-08-30 as "20:00-12:00 Title". This is wrong.

Expected result:
Event should be shown on every day 08-30 to 09-02 and with correct start and end time for this day.

Comment 1

5 years ago
In our case, the printing (monthly view), a 3 days recurring all day event will print only on the first day as: "All Day-All Day Event name".

A fix would be appreciated. Thanks...
(Assignee)

Updated

5 years ago
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
Created attachment 658971 [details] [diff] [review]
regression fix (print on all days)

Patch ensures that the event/task is printed on all days. I had to add some special treatment to cover all cases like end time < start time (e.g. 2012-08-30 20:00 to 2012-09-02 12:00) or to not include an additional day for all-day events.
Attachment #658971 - Flags: review?(philipp)
(Assignee)

Updated

5 years ago
Attachment #658971 - Flags: approval-calendar-beta?
Attachment #658971 - Flags: approval-calendar-aurora?
Comment on attachment 658971 [details] [diff] [review]
regression fix (print on all days)

r=philipp, thanks for the patch!

Very minor nit, could you change:

+            if ( !itemStartDate && !itemEndDate ) {
to:

+            if (!itemStartDate && !itemEndDate) {
Attachment #658971 - Flags: review?(philipp)
Attachment #658971 - Flags: review+
Attachment #658971 - Flags: approval-calendar-beta?
Attachment #658971 - Flags: approval-calendar-beta+
Attachment #658971 - Flags: approval-calendar-aurora?
Attachment #658971 - Flags: approval-calendar-aurora+
(Assignee)

Comment 4

5 years ago
Pushed to https://hg.mozilla.org/comm-central/rev/f181aef1ee3f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0
(Assignee)

Comment 5

5 years ago
Pushed to https://hg.mozilla.org/releases/comm-aurora/rev/042549694f27
Target Milestone: 2.0 → 1.9
(Assignee)

Comment 6

5 years ago
Pushed to https://hg.mozilla.org/releases/comm-beta/rev/c0e72119e5f7
Target Milestone: 1.9 → 1.8
(Assignee)

Updated

5 years ago
Duplicate of this bug: 797855
You need to log in before you can comment on or make changes to this bug.