If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Seamonkey 12.2 keeps dying in process_util_posix.cc and other places with waitpid

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Donald R. Laster jr., Unassigned)

Tracking

SeaMonkey 2.12 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120615 Firefox/13.0.1 SeaMonkey/2.10.1
Build ID: 20120615050029

Steps to reproduce:

Upgrade to Seamonkey 12.2 from version 2.10.1 and Seamonkey won't stay up.  I disabled a number of add-on to no avail.


Actual results:

Seamonkey 2.12 continues to crash with errors such as

WARNING: waitpid failed pid:28295 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: waitpid failed pid:28295 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: Unable to create pipe named "26018.9d59e8f0.826800351" in server mode error(Too many open files).: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 265
WARNING: waitpid failed pid:28295 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: waitpid failed pid:28295 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: Failed to deliver SIGKILL to 28295!(3).: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 129
WARNING: waitpid failed pid:28300 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: Unable to create pipe named "26018.9d59f670.552690461" in server mode error(Too many open files).: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 265
WARNING: waitpid failed pid:28300 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: waitpid failed pid:28300 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
WARNING: Failed to deliver SIGKILL to 28300!(3).: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 129
:WARNING: waitpid failed pid:28303 errno:10: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/process_util_posix.cc, line 255
###!!! ABORT: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/rand_util_posix.cc, line 19
###!!! ABORT: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/base/rand_util_posix.cc, line 19
ExceptionHandler::GenerateDump                                        sys_pipe failed:Too many open files
ExceptionHandler::WaitForContinueSignal                                sys_read failed:Input/output error



Expected results:

Nothing - it should have stayed up and run.
(Reporter)

Comment 1

5 years ago
The underlying hardware and software has not been changed.  Running Slackware 13.0.0.0.0 Linux.
Version: SeaMonkey 2.10 Branch → SeaMonkey 2.12 Branch
(Reporter)

Comment 2

5 years ago
Reverted back to 2.10.1
Was this from our binary, or grabbed from your Distro?
Also note the error throughout your dump:

WARNING: Unable to create pipe named "26018.9d59e8f0.826800351" in server mode error(Too many open files).: file /builds/slave/rel-comm-rel-lnx-bld/build/mozilla/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 265

I suspect you have too few inodes available.
(Reporter)

Comment 5

5 years ago
Binary is from Mozilla.org.  Was downloaded from mozilla.org last night and installed this afternoon.

Comment 6

5 years ago
Wild guess. If you have Flash installed, try disabling the flash plugin via:
Tools->Addons
Go to the Plugins tab.
Disable Flash (and acrobat and anything else inessential).
(Reporter)

Comment 7

5 years ago
Done.  Will see what happens.
(Reporter)

Comment 8

5 years ago
Please note that 2.10.1 was running with all of these enabled.
(Reporter)

Comment 9

5 years ago
Stayed up overnight.  The question now is why did 2.10.1 work fine with the add-ons and plug-ins enabled and 2.12 won't?

Comment 10

5 years ago
Can you provide df -hi output on your system to see if Callek is right?

Comment 11

5 years ago
Did you update Flash at around the same time? Flash protected mode is known to be buggy and rather crashy. The Flash plugin configuration should have a way of turning off protected mode.
(Reporter)

Comment 12

5 years ago
df -hi
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/root               3.0M    459K    2.5M   16% /
/dev/hda3               7.6M     27K    7.6M    1% /opt
/dev/hda4               7.7M     11K    7.7M    1% /usr/local
/dev/hdb1                30M    780K     29M    3% /home
tmpfs                   126K       2    126K    1% /dev/shm

Flash was not upgraded at the time Seamonkey was.  The same flash that was used with 2.10.1 was being used with 2.12.  The date on the flash files are Dec 19, 2012 and Jul 4, 2012. Flash is 11.2 r202 and the page indicates that 11.0r1 is also installed.  Both are disabled at this time.
(In reply to Donald R. Laster jr. from comment #12)
> df -hi
> Filesystem            Inodes   IUsed   IFree IUse% Mounted on
> /dev/root               3.0M    459K    2.5M   16% /
> /dev/hda3               7.6M     27K    7.6M    1% /opt
> /dev/hda4               7.7M     11K    7.7M    1% /usr/local
> /dev/hdb1                30M    780K     29M    3% /home
> tmpfs                   126K       2    126K    1% /dev/shm
> 
> Flash was not upgraded at the time Seamonkey was.  The same flash that was
> used with 2.10.1 was being used with 2.12.  The date on the flash files are
> Dec 19, 2012 and Jul 4, 2012. Flash is 11.2 r202 and the page indicates that
> 11.0r1 is also installed.  Both are disabled at this time.

Ok, so right now the Inode is not an issue -- if this problem returns for SeaMonkey on your system, please re-run that command and comment and [if you're able to] reopen this bug.

I'm going to call it "Worksforme" since I can't reproduce your issue, and right now your system seems to be working fine, as I understand it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.