[Regression] Relative URLs do not function properly in Reader mode

VERIFIED FIXED in Firefox 16

Status

()

P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: mcomella, Assigned: bnicholson)

Tracking

({regression})

18 Branch
Firefox 18
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox16 verified, firefox17 verified, firefox18 verified)

Details

Attachments

(1 attachment)

1) Open Firefox
2) Go to http://en.m.wikipedia.org/wiki/IU_(singer) (Note: last paren probably won't auto-add)
3) Click the reader mode icon
4) Click the "Lost and Found" link (or any other link on the page).

Expected: You are taken to http://en.m.wikipedia.org/wiki/Lost_and_Found_(EP)
Actual: You are taken to http://en.m.wikipedia.org/wiki/Main_Page (you probably actually go to the base URL but are redirected here)

This bug was originally fixed in bug 776110 and has since regressed.
(Assignee)

Comment 1

6 years ago
Created attachment 657527 [details] [diff] [review]
Fix relative URLs in reader mode

Regression from bug 779796. If the URI already begins with slash, there's no need to add another one.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #657527 - Flags: review?(lucasr.at.mozilla)
Attachment #657527 - Flags: review?(lucasr.at.mozilla) → review+
Priority: -- → P1
(Assignee)

Comment 3

6 years ago
Comment on attachment 657527 [details] [diff] [review]
Fix relative URLs in reader mode

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 779796
User impact if declined: links/images won't work for some pages in reader mode
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #657527 - Flags: approval-mozilla-beta?
Attachment #657527 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

6 years ago
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: affected → fixed
Attachment #657527 - Flags: approval-mozilla-beta?
Attachment #657527 - Flags: approval-mozilla-beta+
Attachment #657527 - Flags: approval-mozilla-aurora?
Attachment #657527 - Flags: approval-mozilla-aurora+
Approved for uplift, assuming this lands on central without incident.
https://hg.mozilla.org/mozilla-central/rev/abba691cf404
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
status-firefox17: fixed → verified
status-firefox18: fixed → verified
I cannot reproduce this issue on the latest m-c, m-a and m-b builds. Closing bug as verified fixed.

--
Device: Galaxy Note
OS: Android 4.0.4
You need to log in before you can comment on or make changes to this bug.