Use Search Msg menu when open hidden dialog causes crash.

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P2
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: laurel, Assigned: saari (gone))

Tracking

({crash, pp, regression})

Trunk
mozilla0.9.1
x86
Windows 98
crash, pp, regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+] can't reproduce)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using 2001-05-02-04 commercial trunk build, win98
Doesn't happen on mac, ref: bug 74447 
Doesn't happen on linux, ref: bug 44800

Not sure when this regressed... old condition with resurfacing dialog covered
under bug 44799.

When a search messages dialog is open and hidden behind another window, using
the menu item Search|Search Mail/News Messages will cause the dialog to crash
when it resurfaces.

1.  From mail window, Search|Search Mail/News Messages.
2.  Click/focus in the main mail window.  Mail window comes to foreground,
search dialog is hidden behind mail window.
3.  Use the menu item again.  

Result:  search dialog attempts to resurface in the foreground but crash occurs
before it is fully drawn.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, pp, regression
QA Contact: esther → laurel
(Reporter)

Updated

17 years ago
Blocks: 77232
(Reporter)

Comment 1

17 years ago
Created attachment 33090 [details]
talkback 29965484
(Reporter)

Comment 2

17 years ago
*** Bug 79219 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
reassigning to varada. marking nsbeta1+
Assignee: sspitzer → varada
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1

Comment 4

17 years ago
re-assigning to saari - focus issues.
Assignee: varada → saari
Keywords: mailtrack

Comment 5

17 years ago
P2/0.9.1, adding to XPT App-blockers
Blocks: 75643
Priority: P1 → P2

Comment 6

17 years ago
reproduced on Win98, have another talkback report

Updated

17 years ago
Keywords: crash

Comment 7

17 years ago
Unable to reproduce using NS build 2001051504
Whiteboard: [nsbeta1+] → [nsbeta1+] can't reproduce

Comment 8

17 years ago
There's no crash but the window is unusable.  All of the fields are cleared out
as are the results and you have to close and reopen the window.  Lowering
severity to major.  I don't know if this is still a focus issue.
Severity: critical → major
(Reporter)

Comment 9

17 years ago
No crash in current build, but what putterman last described about it being
unusable is our old friend bug 44799.  

Comment 10

17 years ago
Laurel is right.  Marking this WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

17 years ago
Marking verified (worksforme)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.