New windows use parents character set, not the default

VERIFIED INVALID

Status

()

Core
Internationalization
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Charles Capps, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010503
BuildID:    2001050304

If the page you are viewing is using a character set other than the one you have
selected as your default, and you open a new window (Control + N or File -> New
-> Navigator Window), the new window will open using the parent's character set
rather than the preset default.

If it matters, I have the browser set to open the hompage by default.  The
homepage is set to an existing NN4 bookmark.htm file, which does not contain a
doctype, does not define its own character set, and does not contain the other
nicities of a real live HTML document.  The pages that I'm creating new windows
from are mostly using EUC-KR, but the behavior is the same for other character
sets, i.e. Big5 and the various Arabic charsets.  

Despite using other character sets, only ISO-8859-1 characters are actually
being used on both the source page (using the other character sets) and the
destination.

Reproducible: Always
Steps to Reproduce:
1. Open a page using a character set that you have not set as the default
2. Open a new window while viewing that page
3. Observe the new window load using the character set provided in the 

Actual Results:  The new page loaded using the character set of its parent.  The
default font in use is the default font used by the character set.  The
character set of the parent is selected when viewing View -> Character Coding
rather than the default.

Expected Results:  The new page should have loaded using the default character
set and font.

Comment 1

17 years ago
Yuying, can you reproduce this?  Could this be related to bug 45187?
QA Contact: andreasb → ylong

Comment 2

17 years ago
Currently, when we open a new window (Control + N or File | New | Navigator 
Window), it always open the Netscape home page which is a page with meta charset 
as iso-8859-1, it doesn't matter with which charset in parent window.  So far I 
didn't see the new window charset marked as the charset(different than default) 
in parent window, but since the reporter was using today's build, and I didn't 
see today's win32 build smoke result.  I probably need check it tomorrow.
I guess it might related to bug 45187 but that one was opposite.
Try testing this by using the "open link in new window" context menu option on a
link on page that has a non-default charset....

Comment 4

17 years ago
OK, I tried this page: http://www.yahoo.co.jp and set charset to EUC-JP, the 
page get load correctly.  Then right click on link "Sports" in order to bring up 
a context menu with "open link in new window", click on "Open link in new 
window".  Then you will see the page is garbled, you have to switch charset to 
EUC-JP in order to view that page correctly. 
(Reporter)

Comment 5

17 years ago
I'm only seeing this behavior when hitting control + n / file -> new for a new 
window, not opening up another link in a new window from the page (I use right 
click+new window a LOT).  I don't have any links to external pages from the 
pages with the alternate a character set, so I really didn't think of testing 
that.  

I'm only noticing this when opening a new window and seeing the default homepage 
load, which has no character set defined either in the (non-existant in my case) 
HTTP header or via a meta tag.  

Could it be the fact that I'm loading it from the disk + the lack of any 
character set definition that's causing the problem?

Comment 6

17 years ago
OK, here is a way that you might want to try:
1. Edit | Preferences | Advanced | Cache, clear Memory and Disk cache.
2. Edit | Preferences | Navigator, choose display"Last page visisted" when new
Navigator starts up.
3. Launch the page that you want which using a charset other than default.
4. Then when you click File | New Navigator Window or Cntl + n, will brings up a
new page that with charset in parent's window.

Please note if you don't change the setting in step 2, then the new window will
always open the default netscape home page which is with iso-8859-1 meta-tag page.

I'll mark it as invalid, please re-open it if you are disagree.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 7

17 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.