Image slideshow stops working after navigate other page for 10-15sec

RESOLVED FIXED in mozilla17

Status

()

Core
ImageLib
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

13 Branch
mozilla17
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15-, firefox16-)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-beta/rev/c4e1ca772267
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0 ID:20120828083259

This is spun off Bug 787754.

Image slideshow stops working after navigating other page for 10-15sec.
This happens in 13.0-16.0Beta.
This problem does not happen in Ayrora17.0a2 and Nightly18.0a1.


Steps to reproduce:
1. Open http://shirbo.tekalsites.com/
2. You can confirm to see all pictures by click thumbnails

3. Click link "CONTACT" at the left-top menu
4. Wait for about 10-15 sec
5. Click link "HOME" at the left-top menu

6. Try to click thumbnails to see pictures

Actual results:
 Some pictures are blank.
 The following errors appear in the error cinsole:

Error: Image corrupt or truncated: http://shirbo.tekalsites.com/sites/default/files/styles/image_large/public/slideshow/seawall.jpg
Source file: http://shirbo.tekalsites.com/sites/default/files/styles/image_large/public/slideshow/seawall.jpg

 ....


Expected results:
 All pictures should be drawn properly.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/cdf89e1937eb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120127 Firefox/12.0a1 ID:20120127071251
Bad:
http://hg.mozilla.org/mozilla-central/rev/7ab255f53568
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120127 Firefox/12.0a1 ID:20120127083243
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cdf89e1937eb&tochange=7ab255f53568


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/34b1cc9454d2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120126 Firefox/12.0a1 ID:20120126122051
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/60020371c71b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120126 Firefox/12.0a1 ID:20120126125549
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=34b1cc9454d2&tochange=60020371c71b

Suspected: Bug 715308

Fixed window
Bad:
http://hg.mozilla.org/mozilla-central/rev/3b46b03dff5c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815053101
Working again:
http://hg.mozilla.org/mozilla-central/rev/d67c02074ced
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815065301
Fixed Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3b46b03dff5c&tochange=d67c02074ced

Last bad : a33215aa549c
Working again : d3829aea9cd1

Fixed by Bug 685516

Comment 1

5 years ago
Not a recent regression, and doesn't appear to be causing significant user pain.

CC'ing Kyle to see if bug 685516 is something he'd consider uplifting to Aurora based upon a risk evaluation.
tracking-firefox15: ? → -
tracking-firefox16: ? → -
The patches in the fixed pushlog are quite risky (we already had several functionality and performance regressions we fixed).
Also they should already be on Aurora 17 ...

Updated

5 years ago
Duplicate of this bug: 787754
(Reporter)

Updated

5 years ago
Duplicate of this bug: 787754
Fixed by bug 685516, which we decided not to take any earlier.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
You need to log in before you can comment on or make changes to this bug.