Closed Bug 787774 Opened 10 years ago Closed 10 years ago

builds broken with --system-nspr

Categories

(Firefox Build System :: General, defect)

x86
OpenBSD
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 766038

People

(Reporter: gaston, Unassigned)

Details

Noticed this when building 16.0b1 with nspr 4.9.0 and --with-system-nspr. Build fails with :

/usr/obj/firefox-16.0beta1/mozilla-beta/js/src/jsgc.cpp:2802: error: 'PR_SetCurrentThreadName' was not declared in this scope

Which is one of the funcs added between 4.9.1 and 4.9.2. configure didnt complain, because it seems configure.in in m-c still only checks for nspr 4.9.0, so this affects m-c/m-a/m-b.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766038
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.