Only audio plays, not video

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
6 years ago
3 months ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

17 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When trying http://camendesign.com/code/video_for_everybody/test.html with the current Firefox Aurora on Android, it tries to play H264 video (which in itself seems to me suspicious ... shouldn't Firefox prefer open codecs over proprietary ones?) but it shows only white rectangle. Audio works perfectly, but nothing shows up.
OS: Linux → Android
Hardware: x86_64 → ARM

Comment 1

6 years ago
What device are you playing it on? If it's a Galaxy Nexus, bug 784329.
(Reporter)

Comment 2

6 years ago
Google Nexus S (2nd gen Google phone) with CyanogenMod 10 Nightly.
(In reply to Matej Cepl from comment #0)
> it tries to play H264 video (which in
> itself seems to me suspicious ... shouldn't Firefox prefer open codecs over
> proprietary ones?)

I would like it if we could apply codec preferences, the but spec constrains us to use the first <source> we can successfully play. The page author in this case has chosen to prefer mp4 over webm, and webm over ogv.
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 4

3 months ago
Not sure when, but the latest Firefox on LG G4 works.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.